summaryrefslogtreecommitdiffstats
path: root/eurephia.spec
diff options
context:
space:
mode:
Diffstat (limited to 'eurephia.spec')
-rw-r--r--eurephia.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/eurephia.spec b/eurephia.spec
index 9c7583e..8548514 100644
--- a/eurephia.spec
+++ b/eurephia.spec
@@ -85,6 +85,10 @@ make VERBOSE=1
rm -rf %{buildroot}
make install DESTDIR=%{buildroot}
+# Move the eurephia-auth.so file to the default OpenVPN plug-in directory
+mkdir -p -m 755 %{buildroot}/%{_libdir}/openvpn
+mv %{buildroot}/%{_libdir}/eurephia/eurephia-auth.so %{buildroot}/%{_libdir}/openvpn/
+
# These files are not installed by default, but we want to package them for Fedora/RHEL
install -p -m 755 utils/eurephia_init %{buildroot}/%{_bindir}
install -p -m 755 utils/eurephia_saltdecode %{buildroot}/%{_bindir}
@@ -98,7 +102,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc LICENSE.txt CREDITS.txt
-%{_libdir}/eurephia/eurephia-auth.so
+%{_libdir}/openvpn/eurephia-auth.so
%{_mandir}/man7/eurephia-auth.7.gz
%{_mandir}/man7/eurephia-variables.7.gz
%{_libdir}/eurephia/efw-iptables.so