summaryrefslogtreecommitdiffstats
path: root/eurephia.spec
diff options
context:
space:
mode:
Diffstat (limited to 'eurephia.spec')
-rw-r--r--eurephia.spec44
1 files changed, 37 insertions, 7 deletions
diff --git a/eurephia.spec b/eurephia.spec
index bfb4089..e74f924 100644
--- a/eurephia.spec
+++ b/eurephia.spec
@@ -1,6 +1,6 @@
Name: eurephia
Version: 1.0.0
-Release: 3%{?betatag:.%{betatag}}%{?dist}
+Release: 8%{?betatag:.%{betatag}}%{?dist}
Summary: An advanced and flexible OpenVPN user authentication plug-in
Group: Applications/Internet
@@ -13,7 +13,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}{?betatag:_%{betatag}}-
BuildRequires: libxml2-devel libxslt-devel openssl-devel
BuildRequires: cmake >= 2.6.1
BuildRequires: sqlite-devel >= 3.0.0
-Requires: openvpn eurephia-sqlite3
+Requires: openvpn
+Requires: eurephia-sqlite3 = %{version}-%{release}
%description
This plug-in enhances OpenVPN by adding user name and password
@@ -36,7 +37,7 @@ This package contains the SQLite3 database driver for eurephia
%package iptables
Group: Applications/Internet
Summary: The eurephia iptables interface module
-Requires: eurephia
+Requires: eurephia = %{version}-%{release}
%description iptables
To enable the firewall integration in eurephia, this module must be
@@ -46,7 +47,7 @@ configuration.
%package admin
Group: Applications/Internet
Summary: The eurephia command line administration utility
-Requires: eurephia-sqlite3
+Requires: eurephia-sqlite3 = %{version}-%{release}
%description admin
This package contains the command line utility to administer and configure
@@ -55,7 +56,7 @@ eurephia
%package init
Group: Applications/Internet
Summary: Utility for initializing a new eurephia database
-Requires: eurephia-sqlite3
+Requires: eurephia-sqlite3 = %{version}-%{release}
%description init
This package provides a program which will initialize the eurephia
@@ -76,14 +77,16 @@ hash salt.
%prep
-%setup -q -b0 -n %{name}-%{version}%{?betatag:_%{betatag}}
+%setup -q -n %{name}-%{version}%{?betatag:_%{betatag}}
# This is needed to ship extra until openvpn-plugin.h becomes part of the OpenVPN RPM
-cp -v %{_sourcedir}/openvpn-plugin.h %{_builddir}/%{name}-%{version}%{?betatag:_%{betatag}}/
+cp -v %{SOURCE1} .
%build
# The configure script is not an autotools script, but a cmake wrapper script.
CFLAGS="%{optflags}" ./configure --prefix %{_prefix} --bin-dir %{_bindir} --xslt-path %{_datadir}/eurephia/xslt --plug-in-dir %{_libdir}/eurephia --plug-in --openvpn-src . --fw-iptables --db-sqlite3 --sqlite3-path %{_localstatedir}/lib/eurephia --eurephiadm
+
+# We don't do parallel building, as that might fail.
make VERBOSE=1
%install
@@ -110,6 +113,7 @@ rm -rf %{buildroot}
%files sqlite3
%defattr(-,root,root,-)
%doc LICENSE.txt CREDITS.txt
+%dir %{_libdir}/eurephia/
%{_libdir}/eurephia/edb-sqlite.so
%{_localstatedir}/lib/eurephia/
%{_mandir}/man7/edb-sqlite.7.gz
@@ -129,6 +133,8 @@ rm -rf %{buildroot}
%defattr(-,root,root,-)
%doc LICENSE.txt CREDITS.txt
%{_bindir}/eurephiadm
+%dir %{_datadir}/eurephia/
+%dir %{_datadir}/eurephia/xslt
%{_datadir}/eurephia/xslt/eurephiadm
%{_mandir}/man7/eurephiadm.7.gz
%{_mandir}/man7/eurephiadm-*.7.gz
@@ -140,6 +146,30 @@ rm -rf %{buildroot}
%{_mandir}/man7/eurephia_saltdecode.7.gz
%changelog
+* Thu Jul 15 2010 David Sommerseth <davids@redhat.com> - 1.0.0-8
+- Fixed silly mistakes
+ - Forgot to move over /usr/lib/eurephia from eurephia to eurephia-sqlite3
+ - Double '=' in eurephia-init
+
+* Thu Jul 15 2010 David Sommerseth <davids@redhat.com> - 1.0.0-7
+- More review fixes
+ - Relocated ownership of directories
+ - Don't hard-code version number in intra-package deps
+ - Use proper fully qualified version number (including revision)
+
+* Thu Jul 15 2010 David Sommerseth <davids@redhat.com> - 1.0.0-6
+- Fixed file duplication between eurephia and eurephia-admin
+
+* Thu Jul 15 2010 David Sommerseth <davids@redhat.com> - 1.0.0-5
+- More review comments from mattias.ellert@fysast.uu.se
+ - Own /usr/lib{,64}/eurephia, /usr/share/eurephia/ and /usr/share/eurephia/xslt
+ - Intra-packages use fully qualified versions
+
+* Thu Jul 15 2010 David Sommerseth <davids@redhat.com> - 1.0.0-4
+- Review comments from mattias.ellert@fysast.uu.se
+ - Better way to copy source1
+ - Removed -b0 from setup macro
+
* Thu Jul 8 2010 David Sommerseth <davids@redhat.com> - 1.0.0-3
- Added missing Group tags
- Added stricter cmake version requirement