summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00b0ea8..2f22271 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,6 +30,7 @@ OPTION(SQLITE3 "Build database driver for SQLite3" OFF)
OPTION(EUREPHIADM "Build command line based admin utility" OFF)
OPTION(PLUGIN "Build the eurephia plugin for OpenVPN" OFF)
OPTION(GCOV "Build eurephia with gcov features enabled" OFF)
+OPTION(DOXYGEN "Compile Doxygen documentation" OFF)
# eurephia parameters - string values
SET(OPENVPN_SRC "" CACHE STRING "Path to OpenVPN source code")
@@ -65,9 +66,9 @@ IF(SQLITE3)
ENDIF(SQLITE3)
# Make sure we build at least one database driver
-IF(NOT DATABASE)
+IF(NOT DATABASE AND (EUREPHIADM OR PLUGIN))
message(FATAL_ERROR "Cannot build eurephia without any database drivers.")
-ENDIF(NOT DATABASE)
+ENDIF(NOT DATABASE AND (EUREPHIADM OR PLUGIN))
# eurephiadm - console based admin utility
@@ -163,7 +164,14 @@ ADD_LIBRARY(common STATIC IMPORTED)
SET_PROPERTY(TARGET common PROPERTY IMPORTED_LOCATION ${CMAKE_SOURCE_DIR}/common/libeurephiacommon.a)
# Start the building. First build the common library, and then the requested eurephia modules
-SUBDIRS(common ${subdirs})
+IF(DATABASE OR PLUGIN OR FIREWALL OR EUREPHIADM)
+ SUBDIRS(common ${subdirs})
+ENDIF(DATABASE OR PLUGIN OR FIREWALL OR EUREPHIADM)
+
+# Compile Doxygen docs at the end if requested
+IF(DOXYGEN)
+ SUBDIRS(doxygen)
+ENDIF(DOXYGEN)
# Give warning if DEBUG is enabled
IF(DEBUG)