summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 08110c3..fa9348b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -105,6 +105,16 @@ ENDIF(PLUGIN)
# Check for some standard glibc functions which we need
#
+# Check that we have enidan.h
+CHECK_INCLUDE_FILE(endian.h HAVE_ENDIAN_H)
+IF(NOT HAVE_ENDIAN_H)
+ CHECK_INCLUDE_FILE(sys/endian.h HAVE_SYS_ENDIAN_H)
+ ADD_DEFINITIONS(-DHAVE_SYS_ENDIAN_H)
+ENDIF(NOT HAVE_ENDIAN_H)
+IF(NOT HAVE_ENDIAN_H AND NOT HAVE_SYS_ENDIAN_H)
+ message(FATAL_ERROR "Missing endian.h")
+ENDIF(NOT HAVE_ENDIAN_H AND NOT HAVE_SYS_ENDIAN_H)
+
# Check that we have dynamic loader available
CHECK_INCLUDE_FILE(dlfcn.h HAVE_DLFCN_H)
IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")