summaryrefslogtreecommitdiffstats
path: root/plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-11-05 17:13:34 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-11-05 17:13:34 +0100
commit4764552cbe9747c1b95fad673f943e2e841a176e (patch)
tree2abc12c9747c8cce03421a5d7e7e82a1a9093bf5 /plugin/CMakeLists.txt
parentd07a0b298b767d4e4cdd152cca57c8bf17915b27 (diff)
downloadeurephia-4764552cbe9747c1b95fad673f943e2e841a176e.tar.gz
eurephia-4764552cbe9747c1b95fad673f943e2e841a176e.tar.xz
eurephia-4764552cbe9747c1b95fad673f943e2e841a176e.zip
BUGFIX: Corrected misbehaviour when no firewall interfaces is requested to be built
Diffstat (limited to 'plugin/CMakeLists.txt')
-rw-r--r--plugin/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/plugin/CMakeLists.txt b/plugin/CMakeLists.txt
index 3b21784..60d221f 100644
--- a/plugin/CMakeLists.txt
+++ b/plugin/CMakeLists.txt
@@ -42,4 +42,7 @@ TARGET_LINK_LIBRARIES(eurephia-auth dl pthread rt crypto)
SET_TARGET_PROPERTIES(eurephia-auth PROPERTIES OUTPUT_NAME eurephia-auth PREFIX "")
INSTALL(TARGETS eurephia-auth LIBRARY DESTINATION ${PREFIX})
-SUBDIRS(${subdirs})
+
+IF(subdirs)
+ SUBDIRS(${subdirs})
+ENDIF(subdirs)