summaryrefslogtreecommitdiffstats
path: root/eurephia.spec
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2009-10-07 00:13:20 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2009-10-07 00:13:20 +0200
commit5501786363987737509c2306a9eba9af8d881817 (patch)
tree17b188087c5807978692acc5eafcd72317878ac1 /eurephia.spec
parent3a2290433a654a8b5f07a1db1f8142ec01ca57a7 (diff)
downloadeurephia-5501786363987737509c2306a9eba9af8d881817.tar.gz
eurephia-5501786363987737509c2306a9eba9af8d881817.tar.xz
eurephia-5501786363987737509c2306a9eba9af8d881817.zip
Added RPM spec file for building eurephia RPM packages
Diffstat (limited to 'eurephia.spec')
-rw-r--r--eurephia.spec120
1 files changed, 120 insertions, 0 deletions
diff --git a/eurephia.spec b/eurephia.spec
new file mode 100644
index 0000000..3c2dc81
--- /dev/null
+++ b/eurephia.spec
@@ -0,0 +1,120 @@
+%define betatag beta
+
+Name: eurephia
+Version: 0.9.5
+Release: 1%{?betatag:.%{betatag}}%{?dist}
+Summary: An advanced and flexible OpenVPN user authentication plug-in
+
+Group: Applications/Internet
+License: GPLv2
+URL: http://www.eurephia.net/
+Source0: http://downloads.sourceforge.net/project/eurephia/eurephia/Beta%20releases/%{name}-%{version}%{?betatag:_%{betatag}}.tar.bz2
+Source1: http://openvpn.net/release/openvpn-2.1_rc20.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}{?betatag:_%{betatag}}-root-%(%{__id_u} -n)
+
+BuildRequires: cmake libxml2-devel libxslt-devel sqlite-devel >= 3.0.0
+Requires: openvpn-eurephia eurephia-sqlite3
+
+%description
+This plug-in enhances OpenVPN by adding user name and password
+authentication in addition. An eurephia user account is a combination of
+minimum one OpenVPN SSL certificate and a user name with a password
+assigned. It is also possible to setup several eurephia user names to use
+a shared OpenVPN certificate.
+
+In addition, eurephia will blacklist IP addresses, certificates and usernames
+on too many failed attempts and it supports dynamic update of iptables rules
+which restricts network access per connection.
+
+%package sqlite3
+Summary: The eurephia SQLite3 database driver
+
+%description sqlite3
+This package conatins the SQLite3 database driver for eurephia
+
+%package iptables
+Summary: The eurephia iptables interface module
+Requires: eurephia
+
+%description iptables
+To enable the firewall integration in eurephia, this module must be
+available for eurephia. Use the eurephia-init package to setup
+configuration.
+
+%package admin
+Summary: The eurephia command line administration utility
+Requires: eurephia-sqlite3
+
+%description admin
+This package contains the command line utility to administer and configure
+eurephia
+
+%package init
+Summary: Utility for initialising a new eurephia database
+Requires: eurephia-sqlite3
+
+%description init
+This package provides a program which will initialise the eurephia
+database for you. It will guide you through several questions and
+save the configuration in the database. When you have configured
+and initialised eurephia, this package should be removed from the
+system.
+
+%package utils
+Summary: Misc. eurephia utilities
+
+%description utils
+This package contains useful utilities when debugging eurephia.
+At the moment you will only find saltdecode in this package, which
+will provide some information about the password hash salt.
+
+
+%prep
+%setup -q -b1 -n openvpn-2.1_rc20
+%setup -q -b0 -n %{name}-%{version}%{?betatag:_%{betatag}}
+
+%build
+./configure --prefix %{_prefix} --bin-dir %{_bindir} --xslt-path %{_datadir}/eurephia/xslt --plug-in-dir %{_libdir}/eurephia --plug-in --openvpn-src ../openvpn-2.1_rc20 --fw-iptables --db-sqlite3 --sqlite3-path %{_localstatedir}/lib/eurephia --eurephiadm
+make
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+install -m 755 utils/eurephia_init $RPM_BUILD_ROOT/%{_bindir}
+install -m 755 utils/saltdecode $RPM_BUILD_ROOT/%{_bindir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE.txt CREDITS.txt
+%{_libdir}/eurephia/eurephia-auth.so
+
+%files sqlite3
+%defattr(-,root,root,-)
+%{_libdir}/eurephia/edb-sqlite.so
+%{_localstatedir}/lib/eurephia/
+
+%files iptables
+%defattr(-,root,root,-)
+%{_libdir}/eurephia/efw-iptables.so
+
+%files init
+%defattr(-,root,root,-)
+%{_bindir}/eurephia_init
+
+%files admin
+%defattr(-,root,root,-)
+%{_bindir}/eurephiadm
+%{_datadir}/eurephia/xslt/eurephiadm
+
+%files utils
+%defattr(-,root,root,-)
+%{_bindir}/saltdecode
+
+%changelog
+* Tue Oct 6 2009 David Sommerseth <dazo@users.sourceforge.net> - 0.9.5-1.beta
+- Initial eurephia spec file
+