summaryrefslogtreecommitdiffstats
path: root/database/sqlite/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-11-30 11:15:16 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-11-30 11:15:16 +0100
commitc3059736cbbc58a8ee4a15bd139d652dd9e06772 (patch)
treeca803667c2e3d346a7f1dd24c591d5feb536990c /database/sqlite/CMakeLists.txt
parentf183be8286789874978b68653cc36720db912f16 (diff)
downloadeurephia-c3059736cbbc58a8ee4a15bd139d652dd9e06772.tar.gz
eurephia-c3059736cbbc58a8ee4a15bd139d652dd9e06772.tar.xz
eurephia-c3059736cbbc58a8ee4a15bd139d652dd9e06772.zip
Fixed core dump issue with eDBstore_session_value(...) / (*eDBstore_session_value)(...)
Diffstat (limited to 'database/sqlite/CMakeLists.txt')
-rw-r--r--database/sqlite/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/database/sqlite/CMakeLists.txt b/database/sqlite/CMakeLists.txt
index 7569a36..e0f333a 100644
--- a/database/sqlite/CMakeLists.txt
+++ b/database/sqlite/CMakeLists.txt
@@ -37,6 +37,7 @@ ENDIF(SQLITE3BIN)
TARGET_LINK_LIBRARIES(edb-sqlite sqlite3 crypto)
+ADD_DEFINITIONS(-DDRIVER_MODE)
SET_TARGET_PROPERTIES(edb-sqlite PROPERTIES OUTPUT_NAME edb-sqlite PREFIX "")
SET_SOURCE_FILES_PROPERTIES(${common_files_SRC} PROPERTIES GENERATED true)
SET_DIRECTORY_PROPERTIES(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES eurephiadb)