summaryrefslogtreecommitdiffstats
path: root/database/sqlite/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-12-11 00:05:29 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-12-11 00:05:29 +0100
commit94b035d4a269bf79374d8b43281cb516e5218a6c (patch)
tree1e9d1f6cf3b29f0d0210eec33d496098edbfe712 /database/sqlite/CMakeLists.txt
parentc71f6dab57b454f19f3566b6ed544ff10342ec16 (diff)
downloadeurephia-94b035d4a269bf79374d8b43281cb516e5218a6c.tar.gz
eurephia-94b035d4a269bf79374d8b43281cb516e5218a6c.tar.xz
eurephia-94b035d4a269bf79374d8b43281cb516e5218a6c.zip
Added functions for processing eurephiaACCESSINFO/eurephiaACCESSLIST
Implemented saving VPN access profile to the eurephiaCERTINFO struct and filling the eurephiaACCESSINFO with the proper information needed in the eDBadminGetUserInfo(...) function. The special thing about eurephiaACCESSINFO, is that it will not register duplicate records. And when the eurephiaCERTINFO is free'd, the eurephiaACCESSLIST will automatically be free'd as well.
Diffstat (limited to 'database/sqlite/CMakeLists.txt')
-rw-r--r--database/sqlite/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/database/sqlite/CMakeLists.txt b/database/sqlite/CMakeLists.txt
index 75d13d2..af905ce 100644
--- a/database/sqlite/CMakeLists.txt
+++ b/database/sqlite/CMakeLists.txt
@@ -41,6 +41,9 @@ IF(SQLITE3BIN)
COMMENT "Creating template database: eurephiadb")
ENDIF(SQLITE3BIN)
+IF(FIREWALL)
+ ADD_DEFINITIONS(-DFIREWALL)
+ENDIF(FIREWALL)
TARGET_LINK_LIBRARIES(edb-sqlite sqlite3)
ADD_DEFINITIONS(-DDRIVER_MODE)