summaryrefslogtreecommitdiffstats
path: root/database/sqlite/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-10-15 00:39:53 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-10-15 00:39:53 +0200
commit0ea1a3e2e6a10300388e01ac89504abe3624ae56 (patch)
treefff59c70d4db431c2114e89d0819af8921aff463 /database/sqlite/CMakeLists.txt
parentb65b0802ead5e863ca8cb41fff77528735a1466c (diff)
downloadeurephia-0ea1a3e2e6a10300388e01ac89504abe3624ae56.tar.gz
eurephia-0ea1a3e2e6a10300388e01ac89504abe3624ae56.tar.xz
eurephia-0ea1a3e2e6a10300388e01ac89504abe3624ae56.zip
Reorganised the source code
Moved all OpenVPN plug-in related things into ./plugins, including firewall Moved all shared code into ./common and moved the generic part of the database files into ./database Updated all CMakeLists.txt files and created a new one for the root directory
Diffstat (limited to 'database/sqlite/CMakeLists.txt')
-rw-r--r--database/sqlite/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/database/sqlite/CMakeLists.txt b/database/sqlite/CMakeLists.txt
index db23189..6bdd5e0 100644
--- a/database/sqlite/CMakeLists.txt
+++ b/database/sqlite/CMakeLists.txt
@@ -5,11 +5,11 @@ SET(eurephiadb_sqlite_SRC
eurephiadb-sqlite.c
)
SET(COMMON
- ../../eurephia_log.c
- ../../eurephiadb_session.c
- ../..//eurephia_values.c
- ../../passwd.c
- ../../sha512.c
+ ../../common/eurephia_log.c
+ ../../plugin/eurephiadb_session.c
+ ../../common/eurephia_values.c
+ ../../common/passwd.c
+ ../../common/sha512.c
)
INCLUDE(CheckIncludeFile)
@@ -26,12 +26,14 @@ IF(NOT SQLITE3BIN)
MESSAGE(STATUS "sqlite3 binary was not found. You will need to generate the database file on your own")
ENDIF(NOT SQLITE3BIN)
-INCLUDE_DIRECTORIES(BEFORE ../..)
+INCLUDE_DIRECTORIES(BEFORE ../../common/ ../../plugin/ ../)
ADD_LIBRARY(eurephiadb-sqlite SHARED ${eurephiadb_sqlite_SRC} ${COMMON})
IF(SQLITE3BIN)
ADD_CUSTOM_COMMAND(TARGET eurephiadb-sqlite POST_BUILD COMMAND ${SQLITE3BIN} eurephiadb < sql-schema.sql COMMENT "Creating template database: eurephiadb")
ENDIF(SQLITE3BIN)
+
+
TARGET_LINK_LIBRARIES(eurephiadb-sqlite sqlite3)
SET_TARGET_PROPERTIES(eurephiadb-sqlite PROPERTIES OUTPUT_NAME eurephiadb-sqlite PREFIX "")
SET_SOURCE_FILES_PROPERTIES(${common_files_SRC} PROPERTIES GENERATED true)