summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSeth Vidal <skvidal@fedoraproject.org>2007-09-25 10:27:06 -0400
committerSeth Vidal <skvidal@fedoraproject.org>2007-09-25 10:27:06 -0400
commitfc335d72bd444bc899b07042b7c11c814259f188 (patch)
tree3ba23a23ae5c1698659a3bcae5c511739035d3b2 /setup.py
parent7d543b6cf1d721c2e9f7ed88a230172870a9f558 (diff)
downloadthird_party-func-fc335d72bd444bc899b07042b7c11c814259f188.tar.gz
third_party-func-fc335d72bd444bc899b07042b7c11c814259f188.tar.xz
third_party-func-fc335d72bd444bc899b07042b7c11c814259f188.zip
- all the class bits to make the authssl xmlrpc server work - most of it copied and modified from plague
- modifications to setup.py to behave with func dir for python sitelib
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 4 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index b91f1c6..5948b61 100644
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,7 @@ NAME = "func"
VERSION = open("version", "r+").read().split()[0]
SHORT_DESC = "%s remote configuration and management api" % NAME
LONG_DESC = """
-A small pluggabe xml-rpc daemon used by %s to implement various web services hooks
+A small pluggable xml-rpc daemon used by %s to implement various web services hooks
""" % NAME
@@ -36,13 +36,12 @@ if __name__ == "__main__":
name="%s" % NAME,
version = VERSION,
author = "Lots",
- author_email = "et-mgmt-tools@redhat.com",
+ author_email = "func-list@redhat.com",
url = "https://hosted.fedoraproject.org/projects/func/",
license = "GPL",
- scripts = ["scripts/funcd",
- ],
+ scripts = ["scripts/funcd", "scripts/certmaster"],
# package_data = { '' : ['*.*'] },
- package_dir = {"%s" % NAME: "",
+ package_dir = {"%s" % NAME: "%s" % NAME,
"%s/server" % NAME: "server",
"%s/server/modules" % NAME: "modules/",
"%s/client" % NAME: "client"