summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@redhat.com>2008-04-18 17:31:26 -0400
committerMichael DeHaan <mdehaan@redhat.com>2008-04-18 17:31:26 -0400
commitefbcc041464733e90af670a5d1dfe13e70aaa05c (patch)
treee04450dfaed37ad8757f0e96d5314d36a46444b0 /setup.py
parentb15ca0fe01a01ee6792c857e766642d9d50ab760 (diff)
downloadthird_party-cobbler-efbcc041464733e90af670a5d1dfe13e70aaa05c.tar.gz
third_party-cobbler-efbcc041464733e90af670a5d1dfe13e70aaa05c.tar.xz
third_party-cobbler-efbcc041464733e90af670a5d1dfe13e70aaa05c.zip
Kickstarts are now dynamically generated by mod_python, CGI's now fall
under mod_python, kickstart templating code now moved out of sync function.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index c8a6c99..eb969d1 100644
--- a/setup.py
+++ b/setup.py
@@ -44,8 +44,9 @@ if __name__ == "__main__":
tftp_cfg = "/tftpboot/pxelinux.cfg"
tftp_images = "/tftpboot/images"
rotpath = "/etc/logrotate.d"
- cgipath = "/var/www/cgi-bin/cobbler"
+ # cgipath = "/var/www/cgi-bin/cobbler"
modpython = "/var/www/cobbler/web"
+ modpythonsvc = "/var/www/cobbler/svc"
setup(
name="cobbler",
version = VERSION,
@@ -63,13 +64,15 @@ if __name__ == "__main__":
scripts = ["scripts/cobbler", "scripts/cobblerd"],
data_files = [
(modpython, ['scripts/index.py']),
+ (modpythonsvc, ['scripts/services.py']),
# cgi files
- (cgipath, ['scripts/findks.cgi', 'scripts/nopxe.cgi']),
- (cgipath, ['scripts/install_trigger.cgi']),
+ # (cgipath, ['scripts/nopxe.cgi']),
+ # (cgipath, ['scripts/install_trigger.cgi']),
# miscellaneous config files
(rotpath, ['config/cobblerd_rotate']),
(wwwconf, ['config/cobbler.conf']),
+ (wwwconf, ['config/cobbler_svc.conf']),
(cobpath, ['config/cobbler_hosts']),
(etcpath, ['config/modules.conf']),
(etcpath, ['config/users.digest']),