summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@mdehaan.rdu.redhat.com>2007-07-27 13:34:01 -0400
committerMichael DeHaan <mdehaan@mdehaan.rdu.redhat.com>2007-07-27 13:34:01 -0400
commitdd05c92699e657990c77af311b85fbef30472c11 (patch)
tree25eed399bd27ddcb867c19c1db3724e0e0a92a42 /setup.py
parent31a8dfef9c42b77a17ba09d92651cf222b525a00 (diff)
downloadthird_party-cobbler-dd05c92699e657990c77af311b85fbef30472c11.tar.gz
third_party-cobbler-dd05c92699e657990c77af311b85fbef30472c11.tar.xz
third_party-cobbler-dd05c92699e657990c77af311b85fbef30472c11.zip
Added a SNIPPET::foo feature which can do the equivalent of %include in kickstart without the need
for a wget and http hosting. Snippets live in /var/lib/cobbler/snippets -- Cobbler ships with only one snippet now (as a demo), though users can create as many as they want.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index ba6ecf4..ef9b0b3 100644
--- a/setup.py
+++ b/setup.py
@@ -21,6 +21,7 @@ if __name__ == "__main__":
logpath = "/var/log/cobbler/"
logpath2 = "/var/log/cobbler/kicklog"
logpath3 = "/var/log/cobbler/syslog"
+ snippets = "/var/lib/cobbler/snippets"
vw_localmirror = "/var/www/cobbler/localmirror"
vw_kickstarts = "/var/www/cobbler/kickstarts"
vw_kickstarts_sys = "/var/www/cobbler/kickstarts_sys"
@@ -64,6 +65,7 @@ if __name__ == "__main__":
(etcpath, ['templates/pxesystem.template']),
(etcpath, ['templates/pxesystem_ia64.template']),
(etcpath, ['templates/pxeprofile.template']),
+ (snippets, ['snippets/partition_select']),
(manpath, ['docs/cobbler.1.gz']),
(etcpath, ['config/rsync.exclude']),
(initpath, ['config/cobblerd']),