summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@redhat.com>2007-10-19 15:05:49 -0400
committerMichael DeHaan <mdehaan@redhat.com>2007-10-19 15:05:49 -0400
commitd09c20fc07efb87cffcbac467f189e312eb67e9e (patch)
treec4e7c3b2196afb2ad66bfe30b5e4401e1921caa0 /setup.py
parent8350279beec5475cb1e9eb17ff314ba24d18f6d6 (diff)
downloadthird_party-cobbler-d09c20fc07efb87cffcbac467f189e312eb67e9e.tar.gz
third_party-cobbler-d09c20fc07efb87cffcbac467f189e312eb67e9e.tar.xz
third_party-cobbler-d09c20fc07efb87cffcbac467f189e312eb67e9e.zip
Make RPMs backup the old config, migrate, and conditionally restart the service to make upgrades seamless.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 87fcd39..d064388 100644
--- a/setup.py
+++ b/setup.py
@@ -14,6 +14,7 @@ if __name__ == "__main__":
# docspath="share/doc/koan-%s/" % VERSION
manpath = "share/man/man1/"
cobpath = "/var/lib/cobbler/"
+ backpath = "/var/lib/cobbler/backup/"
etcpath = "/etc/cobbler/"
wwwconf = "/etc/httpd/conf.d/"
wwwpath = "/var/www/cobbler/"
@@ -72,6 +73,9 @@ if __name__ == "__main__":
(initpath, ['config/cobblerd']),
(cobpath, ['config/settings']),
+ # backups for upgrades
+ (backpath, []),
+
# bootloaders and syslinux support files
(cobpath, ['loaders/elilo-3.6-ia64.efi']),
(cobpath, ['loaders/menu.c32']),