summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@mdehaan.rdu.redhat.com>2007-09-19 18:14:03 -0400
committerMichael DeHaan <mdehaan@mdehaan.rdu.redhat.com>2007-09-19 18:14:03 -0400
commit59fcf7bc502d250ea9cec8d9f9b0d2e3233d95e9 (patch)
tree24c5a646550e9977ed6107ef5a0c625143a9d263 /setup.py
parent0204e9181c5274d0c6db6daff4d997776703a9bb (diff)
downloadthird_party-cobbler-59fcf7bc502d250ea9cec8d9f9b0d2e3233d95e9.tar.gz
third_party-cobbler-59fcf7bc502d250ea9cec8d9f9b0d2e3233d95e9.tar.xz
third_party-cobbler-59fcf7bc502d250ea9cec8d9f9b0d2e3233d95e9.zip
Move all CGI scripts to a cobbler subdirectory under cgi-bin for namespacing.
In addition, the webui is now just "webui.cgi" in that directory. RPMs and setup.py also updated.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 49ac3b6..9e2b1b2 100644
--- a/setup.py
+++ b/setup.py
@@ -39,7 +39,7 @@ if __name__ == "__main__":
tftp_cfg = "/tftpboot/pxelinux.cfg"
tftp_images = "/tftpboot/images"
rotpath = "/etc/logrotate.d"
- cgipath = "/var/www/cgi-bin"
+ cgipath = "/var/www/cgi-bin/cobbler"
setup(
name="cobbler",
version = VERSION,
@@ -58,7 +58,7 @@ if __name__ == "__main__":
# cgi files
(cgipath, ['scripts/findks.cgi', 'scripts/nopxe.cgi']),
- (cgipath, ['scripts/cobbler_webui.cgi']),
+ (cgipath, ['scripts/webui.cgi']),
# miscellaneous config files
(rotpath, ['config/cobblerd_rotate']),