summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@redhat.com>2007-12-03 17:38:49 -0500
committerMichael DeHaan <mdehaan@redhat.com>2007-12-03 17:38:49 -0500
commit57ef142ab094e156bb25b077ce16563dfde5a8ff (patch)
treefde4c33234e973071b14826eb7cd7e3bb64e222e /setup.py
parent892d8d4914197c0ab47f397012468752196e8d02 (diff)
downloadthird_party-cobbler-57ef142ab094e156bb25b077ce16563dfde5a8ff.tar.gz
third_party-cobbler-57ef142ab094e156bb25b077ce16563dfde5a8ff.tar.xz
third_party-cobbler-57ef142ab094e156bb25b077ce16563dfde5a8ff.zip
First start of pluggable authn/authz system for remote API + web interface,
using Apache modules.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 05bc079..d8d229f 100644
--- a/setup.py
+++ b/setup.py
@@ -45,6 +45,7 @@ if __name__ == "__main__":
tftp_images = "/tftpboot/images"
rotpath = "/etc/logrotate.d"
cgipath = "/var/www/cgi-bin/cobbler"
+ modpython = "/var/www/cobbler/web"
setup(
name="cobbler",
version = VERSION,
@@ -60,10 +61,10 @@ if __name__ == "__main__":
],
scripts = ["scripts/cobbler", "scripts/cobblerd"],
data_files = [
-
+ (modpython, ['scripts/index.py']),
# cgi files
- (cgipath, ['scripts/findks.cgi', 'scripts/nopxe.cgi']),
- (cgipath, ['scripts/webui.cgi', 'scripts/post_install_trigger.cgi']),
+ (cgipath, ['scripts/findks.cgi', 'scripts/nopxe.cgi']),
+ (cgipath, ['scripts/webui.cgi', 'scripts/post_install_trigger.cgi']),
# miscellaneous config files
(cgipath, ['config/.htaccess']),