summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@redhat.com>2007-11-29 14:58:46 -0500
committerMichael DeHaan <mdehaan@redhat.com>2007-11-29 14:58:46 -0500
commit231ef515b22aa0204c625340f492eba651ef4bae (patch)
treef835e671d7c233e6c71ec7b1c1af58a6f76de7d7 /setup.py
parentbddd3d6affa106b800f9ad1ec25f0dcfed750604 (diff)
downloadthird_party-cobbler-231ef515b22aa0204c625340f492eba651ef4bae.tar.gz
third_party-cobbler-231ef515b22aa0204c625340f492eba651ef4bae.tar.xz
third_party-cobbler-231ef515b22aa0204c625340f492eba651ef4bae.zip
Initial application of Tim V's patch to enable post install triggers.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 04ba3ec..2a1acfc 100644
--- a/setup.py
+++ b/setup.py
@@ -63,7 +63,7 @@ if __name__ == "__main__":
# cgi files
(cgipath, ['scripts/findks.cgi', 'scripts/nopxe.cgi']),
- (cgipath, ['scripts/webui.cgi']),
+ (cgipath, ['scripts/webui.cgi', 'scripts/postinstalltrigger.cgi']),
# miscellaneous config files
(cgipath, ['config/.htaccess']),
@@ -192,6 +192,7 @@ if __name__ == "__main__":
("%sdelete/repo/pre" % trigpath, []),
("%sdelete/repo/post" % trigpath, []),
("%sdelete/repo/post" % trigpath, []),
+ ("%sinstall/post" % trigpath, []),
("%ssync/pre" % trigpath, []),
("%ssync/post" % trigpath, [ "triggers/restart-services.trigger" ])
],