summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f97610..1fe60ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,7 +49,8 @@ $(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
$(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
libvirt.py: $(srcdir)/libvir.py libvirtclass.py
- cat $(srcdir)/libvir.py libvirtclass.py > libvirt.py
+ cat $(srcdir)/libvir.py libvirtclass.py > $@-t
+ mv $@-t $@
$(libvirtmod_la_OBJECTS): $(GENERATED)
@@ -60,6 +61,9 @@ install-data-local:
@(for doc in $(DOCS) ; \
do @INSTALL@ -m 0644 $$doc $(DESTDIR)$(DOCS_DIR) ; done)
+uninstall-local:
+ rm -f $(DESTDIR)$(pythondir)/libvirt.py
+
CLEANFILES= $(GENERATED) libvirt.py
else