summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2011-05-12 11:19:42 +0100
committerDaniel P. Berrange <berrange@redhat.com>2011-07-19 13:58:06 +0100
commite9b7031c8a1114c0aea68fac97a80e895c8fdd85 (patch)
treee67e6b971a900479ae6bf0b24a575a5adddb35aa /Makefile.am
parent140b8f2c12f1dc832cc0daa676548db246307c1b (diff)
downloadlibvirt-python-split-e9b7031c8a1114c0aea68fac97a80e895c8fdd85.tar.gz
libvirt-python-split-e9b7031c8a1114c0aea68fac97a80e895c8fdd85.tar.xz
libvirt-python-split-e9b7031c8a1114c0aea68fac97a80e895c8fdd85.zip
Quieten build & ensure API build scripts exit with non-zero status
The current API build scripts will continue and exit with a zero status even if they find problems. This has been the cause of many build problems, or hidden build errors, in the past. Change the scripts so they always exit with a non-zero status for any problems they do not understand. Also turn off all debug output by default so they respect $(AM_V_GEN) * docs/Makefile.am: Use $(AM_V_GEN) for API/HTML scripts * docs/apibuild.py, python/generator.py: Exit with non-zero status if problems are found. Also be silent, not outputting any debug messages. * src/Makefile.am: Use $(AM_V_GEN) for ESX generator * python/Makefile.am: Tweak rule
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0edb3e4..a4c9a6b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,11 +53,11 @@ GENERATED= libvirt-export.c \
libvirt.h \
libvirt.py
-generated.stamp: $(srcdir)/$(GENERATE) $(API_DESC)
- $(PYTHON) $(srcdir)/$(GENERATE) $(PYTHON)
+$(GENERATE).stamp: $(srcdir)/$(GENERATE) $(API_DESC)
+ $(AM_V_GEN)$(PYTHON) $(srcdir)/$(GENERATE) $(PYTHON) && \
touch $@
-$(GENERATED): generated.stamp
+$(GENERATED): $(GENERATE).stamp
$(libvirtmod_la_OBJECTS): $(GENERATED)