summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Bolte <matthias.bolte@googlemail.com>2009-12-12 00:11:31 +0100
committerMatthias Bolte <matthias.bolte@googlemail.com>2009-12-14 22:14:06 +0100
commitbdbb7aa1239a35c8b9c96d2aa59251cd8be0bdc1 (patch)
tree869e8798fa1c0e6d3335bf1be9e61f5129089163 /Makefile.am
parent6d1c8a436dc5b543ba2ad56b453a34ce43d9ba14 (diff)
downloadlibvirt-python-split-bdbb7aa1239a35c8b9c96d2aa59251cd8be0bdc1.tar.gz
libvirt-python-split-bdbb7aa1239a35c8b9c96d2aa59251cd8be0bdc1.tar.xz
libvirt-python-split-bdbb7aa1239a35c8b9c96d2aa59251cd8be0bdc1.zip
Fix install location for Python bindings
Commit 66137344feb488ea87b0d92f3c03844d9a7a7786 changed the Python detection mechanism in configure to use AM_PATH_PYTHON. This results in a changed install location for the Python bindings, at least on Fedora 12 64bit systems. Before this commit libvirt.py and libvirtmod.so were installed to /usr/lib64/python2.6/site-packages After this commit they are installed to /usr/lib/python2.6/site-packages Mixed Python packages (containing *.py and *.so files) should be installed to the pyexecdir directory detected by AM_PATH_PYTHON. This restores the install location from before the AM_PATH_PYTHON commit. * configure.in: remove unnecessary pythondir export * python/Makefile.am: switch from pythondir to pyexecdir
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 736631e..04342b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,7 @@ mylibs = $(top_builddir)/src/libvirt.la
all-local: libvirt.py
-python_LTLIBRARIES = libvirtmod.la
+pyexec_LTLIBRARIES = libvirtmod.la
libvirtmod_la_SOURCES = libvirt-override.c typewrappers.c libvirt.c libvirt.h
# Python <= 2.4 header files contain a redundant decl, hence we
@@ -60,14 +60,14 @@ $(GENERATED): generated.stamp
$(libvirtmod_la_OBJECTS): $(GENERATED)
install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(pythondir)
- @INSTALL@ -m 0644 libvirt.py $(DESTDIR)$(pythondir)
+ $(mkinstalldirs) $(DESTDIR)$(pyexecdir)
+ @INSTALL@ -m 0644 libvirt.py $(DESTDIR)$(pyexecdir)
$(mkinstalldirs) $(DESTDIR)$(DOCS_DIR)
@(for doc in $(DOCS) ; \
do @INSTALL@ -m 0644 $$doc $(DESTDIR)$(DOCS_DIR) ; done)
uninstall-local:
- rm -f $(DESTDIR)$(pythondir)/libvirt.py
+ rm -f $(DESTDIR)$(pyexecdir)/libvirt.py
CLEANFILES= $(GENERATED) generated.stamp