summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2007-11-15 13:04:28 +0000
committerJim Meyering <meyering@redhat.com>2007-11-15 13:04:28 +0000
commit41d53adb8bc4c487ac085f516664d10d8856cc09 (patch)
treefa690958806fd292fec77646b8a852763863f347 /Makefile.am
parenta4e8e2c99ad3f5d8fe01885caedc95e303eec5e8 (diff)
downloadlibvirt-python-split-41d53adb8bc4c487ac085f516664d10d8856cc09.tar.gz
libvirt-python-split-41d53adb8bc4c487ac085f516664d10d8856cc09.tar.xz
libvirt-python-split-41d53adb8bc4c487ac085f516664d10d8856cc09.zip
Make "make distcheck" work.
* Makefile.am: Expand some "*" wildcards, and (for now) disable the relatively unimportant, distuninstallcheck target. Fix a few redirect-directly-to-target bugs. Add a few $(srcdir)/ prefixes and add an uninstall-local rule. * docs/Makefile.am: More of the same. Split some long lines. * python/Makefile.am: Likewise. * python/tests/Makefile.am: Likewise. * qemud/Makefile.am: Likewise. * tests/Makefile.am: Remove the directories already listed in SUBDIRS. * docs/examples/index.py: Adapt to produce the desired changes in docs/examples/Makefile.am. Also, sort *.c, so results are reproducible, and emit a comment telling emacs and vi that the file is read-only. * docs/examples/Makefile.am: Regenerate. Author: Jim Meyering <meyering@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f97610..1fe60ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,7 +49,8 @@ $(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
$(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
libvirt.py: $(srcdir)/libvir.py libvirtclass.py
- cat $(srcdir)/libvir.py libvirtclass.py > libvirt.py
+ cat $(srcdir)/libvir.py libvirtclass.py > $@-t
+ mv $@-t $@
$(libvirtmod_la_OBJECTS): $(GENERATED)
@@ -60,6 +61,9 @@ install-data-local:
@(for doc in $(DOCS) ; \
do @INSTALL@ -m 0644 $$doc $(DESTDIR)$(DOCS_DIR) ; done)
+uninstall-local:
+ rm -f $(DESTDIR)$(pythondir)/libvirt.py
+
CLEANFILES= $(GENERATED) libvirt.py
else