summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2006-02-14 14:30:42 +0000
committerDaniel Veillard <veillard@redhat.com>2006-02-14 14:30:42 +0000
commit8272e2a036b6d0659242b65f55b5e7b3c28f0341 (patch)
treea8d100f0810f9cb49f19bcadc5309fc14f094cc3 /Makefile.am
parent1672f4f9401931f90f0ea8e474f26dcfdf9f6258 (diff)
downloadlibvirt-python-split-8272e2a036b6d0659242b65f55b5e7b3c28f0341.tar.gz
libvirt-python-split-8272e2a036b6d0659242b65f55b5e7b3c28f0341.tar.xz
libvirt-python-split-8272e2a036b6d0659242b65f55b5e7b3c28f0341.zip
* Makefile.am configure.in python/Makefile.am python/tests/Makefile.am
python/tests/basic.py: added first python test script and a 'make tests' target Daniel
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b0eb78e..a31c17d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,7 @@
# Makefile for libvirt python library
+SUBRIRS= . tests
+
INCLUDES = \
-I$(PYTHON_INCLUDES) \
-I$(top_srcdir)/include \
@@ -60,3 +62,8 @@ $(libvirtmod_la_OBJECTS): $(GENERATED)
else
all:
endif
+
+dummy:
+
+tests test: all dummy
+ -@(cd tests && $(MAKE) MAKEFLAGS+=--silent tests)