summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2007-03-06 21:55:44 +0000
committerDaniel P. Berrange <berrange@redhat.com>2007-03-06 21:55:44 +0000
commitf928d2b27fce6b225d7325702226f159c3014b66 (patch)
tree34661964e0fe7fc9a226bcfd9cf1102be1a4c5c2 /Makefile.am
parentbffcc4f8a22e28b55b18ef434ba2d860e4d4389b (diff)
downloadlibvirt-python-split-f928d2b27fce6b225d7325702226f159c3014b66.tar.gz
libvirt-python-split-f928d2b27fce6b225d7325702226f159c3014b66.tar.xz
libvirt-python-split-f928d2b27fce6b225d7325702226f159c3014b66.zip
Fixed up numerous compiler warnings
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d8ffd14..dbb471d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,9 @@ all-local: libvirt.py
python_LTLIBRARIES = libvirtmod.la
libvirtmod_la_SOURCES = libvir.c types.c libvirt-py.c libvirt-py.h
-libvirtmod_la_LIBADD = $(mylibs)
+libvirtmod_la_LIBADD = $(mylibs)
+# Python header files contain a redundant decl, hence:
+libvirtmod_la_CFLAGS = -Wno-redundant-decls
libvirt.py: $(srcdir)/libvir.py libvirtclass.py
cat $(srcdir)/libvir.py libvirtclass.py > libvirt.py