summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilipp Hahn <hahn@univention.de>2010-04-15 12:49:33 +0200
committerEric Blake <eblake@redhat.com>2010-04-20 08:13:06 -0600
commite4affdfbc19a6bd2778acf0e64a947cecd7eea83 (patch)
treeeab7e9577cf812a28abc2681bd9a7fa70975cb74 /Makefile.am
parent37f24b06c0f96539f8964e0b41010f4ebe514f5f (diff)
downloadlibvirt-python-split-e4affdfbc19a6bd2778acf0e64a947cecd7eea83.tar.gz
libvirt-python-split-e4affdfbc19a6bd2778acf0e64a947cecd7eea83.tar.xz
libvirt-python-split-e4affdfbc19a6bd2778acf0e64a947cecd7eea83.zip
Don't ship generated python/libvirt.? files.
libvirt.c and libvirt.h are auto-generated files. Mentioning their names in *_SOURCES includes them in the distribution. During an out-of-tree build these shipped files are included instead of the auto-generated version, potentially breaking the build (as it happend in 0.8.0, because the shipped libvirt.h was missing the declaration for 'libvirt_virDomainUpdateDeviceFlags') Use the nodist_*_SOURCES automake variable instead. Signed-off-by: Philipp Hahn <hahn@univention.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6b67e38..eda2866 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,8 @@ all-local: libvirt.py
pyexec_LTLIBRARIES = libvirtmod.la
-libvirtmod_la_SOURCES = libvirt-override.c typewrappers.c libvirt.c libvirt.h
+libvirtmod_la_SOURCES = libvirt-override.c typewrappers.c
+nodist_libvirtmod_la_SOURCES = libvirt.c libvirt.h
# Python <= 2.4 header files contain a redundant decl, hence we
# need extra flags here
libvirtmod_la_CFLAGS = $(WARN_PYTHON_CFLAGS)