summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2007-11-29 17:44:01 +0000
committerRichard W.M. Jones <rjones@redhat.com>2007-11-29 17:44:01 +0000
commitb4cd1d2dd90974f3c10751dbbae5067a4eaced89 (patch)
tree040fd08bf70f538db139814d9079f0960938d964 /Makefile.am
parent41d53adb8bc4c487ac085f516664d10d8856cc09 (diff)
downloadlibvirt-python-split-b4cd1d2dd90974f3c10751dbbae5067a4eaced89.tar.gz
libvirt-python-split-b4cd1d2dd90974f3c10751dbbae5067a4eaced89.tar.xz
libvirt-python-split-b4cd1d2dd90974f3c10751dbbae5067a4eaced89.zip
Thu Nov 29 17:40:00 GMT 2007 Richard W.M. Jones <rjones@redhat.com>
* configure.in: Added CYGWIN_EXTRA_LDFLAGS, CYGWIN_EXTRA_LIBADD, CYGWIN_EXTRA_PYTHON_LIBADD, CYGWIN automake conditional. * src/Makefile.am: Extra flags required to build DLL of libvirt for Cygwin. * python/Makefile.am: Extra flags and rule required to build Python module for Cygwin.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1fe60ff..d021567 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,8 +23,6 @@ EXTRA_DIST = \
libvirt-python-api.xml \
$(DOCS)
-libvirtmod_la_LDFLAGS = -module -avoid-version -L$(top_builddir)/src/.libs
-
if WITH_PYTHON
mylibs = $(top_builddir)/src/libvirt.la
@@ -33,10 +31,14 @@ all-local: libvirt.py
python_LTLIBRARIES = libvirtmod.la
libvirtmod_la_SOURCES = libvir.c types.c libvirt-py.c libvirt-py.h
-libvirtmod_la_LIBADD = $(mylibs)
# Python header files contain a redundant decl, hence:
libvirtmod_la_CFLAGS = -Wno-redundant-decls
+libvirtmod_la_LDFLAGS = -module -avoid-version -L$(top_builddir)/src/.libs \
+ @CYGWIN_EXTRA_LDFLAGS@
+libvirtmod_la_LIBADD = $(mylibs) \
+ @CYGWIN_EXTRA_LIBADD@ @CYGWIN_EXTRA_PYTHON_LIBADD@
+
GENERATE = generator.py
API_DESC = $(top_srcdir)/docs/libvirt-api.xml $(srcdir)/libvirt-python-api.xml
GENERATED= libvirt-export.c \
@@ -61,6 +63,13 @@ install-data-local:
@(for doc in $(DOCS) ; \
do @INSTALL@ -m 0644 $$doc $(DESTDIR)$(DOCS_DIR) ; done)
+if CYGWIN
+install-data-hook:
+ cd $(DESTDIR)$(pythondir) && \
+ rm -f libvirtmod.dll && \
+ ln -s cygvirtmod.dll libvirtmod.dll
+endif
+
uninstall-local:
rm -f $(DESTDIR)$(pythondir)/libvirt.py