summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gmail.com>2010-01-06 17:33:41 +0100
committerDaniel Veillard <veillard@redhat.com>2010-01-06 17:33:41 +0100
commita6c8acd06dc71e000d1080ed9fa426211462e016 (patch)
tree98bb2a54c79e7156484c2420c5726ab59b2326a7 /Makefile.am
parentd8d01cc94ce4a2955ef272319429dfd5a3e9df01 (diff)
downloadlibvirt-python-split-a6c8acd06dc71e000d1080ed9fa426211462e016.tar.gz
libvirt-python-split-a6c8acd06dc71e000d1080ed9fa426211462e016.tar.xz
libvirt-python-split-a6c8acd06dc71e000d1080ed9fa426211462e016.zip
Disable building of static Python module
* python/Makefile.am: python modules are loaded at runtime so the static version is not needed, avoid building it
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 04342b7..58c6729 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,7 @@ libvirtmod_la_SOURCES = libvirt-override.c typewrappers.c libvirt.c libvirt.h
# need extra flags here
libvirtmod_la_CFLAGS = @WARN_PYTHON_CFLAGS@
-libvirtmod_la_LDFLAGS = -module -avoid-version -L$(top_builddir)/src/.libs \
+libvirtmod_la_LDFLAGS = -module -avoid-version -shared -L$(top_builddir)/src/.libs \
@CYGWIN_EXTRA_LDFLAGS@
libvirtmod_la_LIBADD = $(mylibs) \
@CYGWIN_EXTRA_LIBADD@ @CYGWIN_EXTRA_PYTHON_LIBADD@