summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2006-02-28 12:17:00 +0000
committerDaniel Veillard <veillard@redhat.com>2006-02-28 12:17:00 +0000
commit9600409e58e3580ccd0e46c1da2c6a019a01ec02 (patch)
tree4a67bb2fcd028692ae616461145c0c19382f08d8 /Makefile.am
parent8a85b2bf232d251c5c688721b68145fc21bf3581 (diff)
downloadlibvirt-python-split-9600409e58e3580ccd0e46c1da2c6a019a01ec02.tar.gz
libvirt-python-split-9600409e58e3580ccd0e46c1da2c6a019a01ec02.tar.xz
libvirt-python-split-9600409e58e3580ccd0e46c1da2c6a019a01ec02.zip
* TODO: updated
* python/Makefile.am python/generator.py python/libvir.c python/libvir.py: improved python binding, raise exception when an instance creation or lookup fails, and add support for the global error handler, per conn handler still needed * python/tests/error.py python/tests/Makefile.am: adding a regression test Daniel
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c57b9f7..96865a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,7 @@ EXTRA_DIST = \
generator.py \
libvirt_wrap.h \
libvirt.py \
+ libvir.py \
libvirt-python-api.xml \
$(DOCS)
@@ -33,6 +34,8 @@ python_LTLIBRARIES = libvirtmod.la
libvirtmod_la_SOURCES = libvir.c types.c libvirt-py.c libvirt-py.h
libvirtmod_la_LIBADD = $(mylibs)
+libvirt.py: $(srcdir)/libvir.py libvirtclass.py
+ cat $(srcdir)/libvir.py libvirtclass.py > libvirt.py
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(pythondir)