summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2007-06-26 13:47:04 +0000
committerRichard W.M. Jones <rjones@redhat.com>2007-06-26 13:47:04 +0000
commit61177b29d4fb30df3f6c0324981117046590c306 (patch)
treefef27d212ab68129912c13ab1834b4ff66fb2da7 /Makefile.am
parent51a0571b597470e479ef884c8772d792a29c6b19 (diff)
downloadlibvirt-python-split-61177b29d4fb30df3f6c0324981117046590c306.tar.gz
libvirt-python-split-61177b29d4fb30df3f6c0324981117046590c306.tar.xz
libvirt-python-split-61177b29d4fb30df3f6c0324981117046590c306.zip
Tue Jun 26 14:40:00 BST 2007 Richard W.M. Jones <rjones@redhat.com>v0.3.0
* src/remote_internal.c, python/Makefile.am: Python bindings fixed, and now building virConnect.getHostname and virConnect.getURI. Fixed a problem which stopped libvirt.py from being (re-)built. Rearranged python/Makefile.am to make it cleaner and clearer.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 14 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index dbb471d..4f97610 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,35 +37,31 @@ libvirtmod_la_LIBADD = $(mylibs)
# Python header files contain a redundant decl, hence:
libvirtmod_la_CFLAGS = -Wno-redundant-decls
-libvirt.py: $(srcdir)/libvir.py libvirtclass.py
- cat $(srcdir)/libvir.py libvirtclass.py > libvirt.py
-
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(pythondir)
- @INSTALL@ -m 0644 libvirt.py $(DESTDIR)$(pythondir)
- $(mkinstalldirs) $(DESTDIR)$(DOCS_DIR)
- @(for doc in $(DOCS) ; \
- do @INSTALL@ -m 0644 $$doc $(DESTDIR)$(DOCS_DIR) ; done)
-
GENERATE = generator.py
API_DESC = $(top_srcdir)/docs/libvirt-api.xml $(srcdir)/libvirt-python-api.xml
-GENERATED= libvirt.py \
- libvirt-export.c \
+GENERATED= libvirt-export.c \
libvirtclass.txt \
libvirt-py.c \
libvirt-py.h \
libvirtclass.py
-CLEANFILES= $(GENERATED) gen_prog libvirt.py
-
-$(GENERATED): gen_prog
-
-gen_prog: $(srcdir)/$(GENERATE) $(API_DESC)
+$(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
$(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
- touch gen_prog
+
+libvirt.py: $(srcdir)/libvir.py libvirtclass.py
+ cat $(srcdir)/libvir.py libvirtclass.py > libvirt.py
$(libvirtmod_la_OBJECTS): $(GENERATED)
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(pythondir)
+ @INSTALL@ -m 0644 libvirt.py $(DESTDIR)$(pythondir)
+ $(mkinstalldirs) $(DESTDIR)$(DOCS_DIR)
+ @(for doc in $(DOCS) ; \
+ do @INSTALL@ -m 0644 $$doc $(DESTDIR)$(DOCS_DIR) ; done)
+
+CLEANFILES= $(GENERATED) libvirt.py
+
else
all:
endif