summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-02-02 13:20:09 -0700
committerEric Blake <eblake@redhat.com>2012-02-03 10:36:02 -0700
commit1104c3ed216f3f46cfe62afbe70bb95f90787f69 (patch)
treef700734d7335cd773748300c4dcd9222b8dc6911 /Makefile.am
parent340ef52421ef1ac903a97b64ab0572da05175970 (diff)
downloadlibvirt-python-split-1104c3ed216f3f46cfe62afbe70bb95f90787f69.tar.gz
libvirt-python-split-1104c3ed216f3f46cfe62afbe70bb95f90787f69.tar.xz
libvirt-python-split-1104c3ed216f3f46cfe62afbe70bb95f90787f69.zip
build: clean up CPPFLAGS/INCLUDES usage
Our syntax checker missed all-lower-case variables (this will be fixed by the next .gnulib update). Additionally, anywhere that we mix in-tree files with generated files, automake recommends listing builddir prior to srcdir for VPATH builds. * src/Makefile.am (*_la_CFLAGS): Favor $(top_srcdir). (INCLUDES): Likewise, and follow automake recommendations on builddir before srcdir. * python/Makefile.am (INCLUDES): Swap directory order. * tests/Makefile.am (INCLUDES): Likewise. * tools/Makefile.am (INCLUDES): Likewise. * daemon/Makefile.am (INCLUDES): Likewise. (libvirtd.init, libvirtd.service): Favor $(). * examples/hellolibvirt/Makefile.am (hellolibvirt_LDADD): Likewise. * examples/openauth/Makefile.am (openauth_LDADD): Likewise. * examples/dominfo/Makefile.am (INCLUDES): Drop dead include. * examples/domsuspend/Makefile.am (INCLUDES): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3068eee..81b160a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,14 +1,14 @@
# Makefile for libvirt python library
-## Copyright (C) 2005-2011 Red Hat, Inc.
+## Copyright (C) 2005-2012 Red Hat, Inc.
## See COPYING.LIB for the License of this software
SUBDIRS= . tests
INCLUDES = \
$(PYTHON_INCLUDES) \
- -I$(top_srcdir)/include \
-I$(top_builddir)/include \
+ -I$(top_srcdir)/include \
-I$(top_builddir)/$(subdir) \
$(GETTEXT_CPPFLAGS)