summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2008-10-31 10:13:45 +0000
committerDaniel Veillard <veillard@redhat.com>2008-10-31 10:13:45 +0000
commit000818421b5007e1ee65c3fa8fef12bcf08feea2 (patch)
tree2dfd825507d5c75d1ee393bf229706f48dcf2f56 /Makefile.am
parent494cd4b4c291391cc5f4f3c20e4f60667c1dd2fb (diff)
downloadlibvirt-python-split-000818421b5007e1ee65c3fa8fef12bcf08feea2.tar.gz
libvirt-python-split-000818421b5007e1ee65c3fa8fef12bcf08feea2.tar.xz
libvirt-python-split-000818421b5007e1ee65c3fa8fef12bcf08feea2.zip
* python/Makefile.am python/generator.py python/libvir.c
python/libvir.py python/libvirt_wrap.h python/types.c: adds support for events from the python bindings, also improves the generator allowing to embbed per function definition files, patch by Ben Guthro * examples/domain-events/events-python/event-test.py: also adds a programming example Daniel
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cd9b6af..90b87bb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,6 +13,8 @@ DOCS_DIR = $(datadir)/doc/libvirt-python-$(LIBVIRT_VERSION)
DOCS = ${srcdir}/TODO
+CLASSES_EXTRA = virConnect.py
+
EXTRA_DIST = \
libvir.c \
types.c \
@@ -21,6 +23,7 @@ EXTRA_DIST = \
libvirt.py \
libvir.py \
libvirt-python-api.xml \
+ $(CLASSES_EXTRA) \
$(DOCS)
if WITH_PYTHON
@@ -50,7 +53,7 @@ GENERATED= libvirt-export.c \
$(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
$(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
-libvirt.py: $(srcdir)/libvir.py $(GENERATED)
+libvirt.py: $(srcdir)/libvir.py $(GENERATED) $(CLASSES_EXTRA)
cat $(srcdir)/libvir.py libvirtclass.py > $@-t
mv $@-t $@