summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 844c824..30db941 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,10 +52,14 @@ pkgpython_PYTHON = \
CLEANFILES += py/*.pyc py/mock/*.pyc py/mock/plugins/*.pyc
-dist: ChangeLog
+dist: ChangeLog AUTHORS
ChangeLog:
(GIT_DIR=.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+AUTHORS:
+ (GIT_DIR=.git git-log | grep ^Author | sort |uniq > .authors.tmp && mv .authors.tmp AUTHORS; rm -f .authors.tmp) || (touch AUTHORS; echo 'git directory not found: installing possibly empty AUTHORS.' >&2)
+
+
REPLACE_VARS_ON_INSTALL=$(sbindir)/mock.py
install-exec-hook:
for i in $(REPLACE_VARS_ON_INSTALL); do \