summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael E Brown <michael_e_brown@dell.com>2007-10-18 17:22:13 -0500
committerMichael E Brown <michael_e_brown@dell.com>2007-10-18 17:22:13 -0500
commit1763fc3d166624ff101b198fcd76db5e0d8a94a7 (patch)
tree18034265e6b016a94ac2357f5b24d3c739dc59ec /Makefile.am
parent9d4e909bdb995734fb80a074cbfee90b1d0f2dee (diff)
downloadmock-1763fc3d166624ff101b198fcd76db5e0d8a94a7.tar.gz
mock-1763fc3d166624ff101b198fcd76db5e0d8a94a7.tar.xz
mock-1763fc3d166624ff101b198fcd76db5e0d8a94a7.zip
finally fix deps for src/mock.py so it is re-edited at correct times.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index e4ff498..af63458 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,9 +50,12 @@ pkgpython_PYTHON = \
src/py-libs/trace_decorator.py \
src/py-libs/uid.py
-$(top_builddir)/src/mock.py: $(top_srcdir)/src/mock.py
+ # indent a space to get around automake
+ ifneq ($(top_builddir),$(top_srcdir))
+ $(top_builddir)/src/mock.py: $(top_srcdir)/src/mock.py
+ endif
-src/mock.py: configure.ac Makefile.am
+src/mock.py: Makefile
echo Updating $@, current pwd: $$(pwd)
cp -f $(top_srcdir)/$@ $(top_builddir)/$@.new
perl -p -i -e 's|^__VERSION__=.*|__VERSION__="$(RELEASE_VERSION)"|' $(top_builddir)/$@.new
@@ -63,8 +66,6 @@ src/mock.py: configure.ac Makefile.am
rm -f $(top_builddir)/$@.new
chmod +x $(top_builddir)/$@ || :
-
-
rpm: dist
BLD_DIR=$$(mktemp -d /tmp/rpmbuild-$$$$-XXXXXX); \
mkdir -p $$BLD_DIR/SOURCES $$BLD_DIR/BUILD $$BLD_DIR/RPMS $$BLD_DIR/RPMS/i386 $$BLD_DIR/RPMS/noarch $$BLD_DIR/SRPMS $$BLD_DIR/SPECS ;\