summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTodd Zullinger <tmz@pobox.com>2009-01-07 18:59:21 -0500
committerMichael E Brown <mebrown@michaels-house.net>2009-01-07 18:14:52 -0600
commita9c9f083e197a9ffe83003230b635730af66e3ba (patch)
tree06749fa1a6a1efae4278c065066b44ac360ee259 /Makefile.am
parent324ef3f812b15dfe4fc552f8962020f4ba0a8e35 (diff)
downloadmock-a9c9f083e197a9ffe83003230b635730af66e3ba.tar.gz
mock-a9c9f083e197a9ffe83003230b635730af66e3ba.tar.xz
mock-a9c9f083e197a9ffe83003230b635730af66e3ba.zip
Fix git log command used for ChangeLog and AUTHORS
The git-* commands are not in the PATH by default with git >= 1.6.0. Signed-off-by: Todd Zullinger <tmz@pobox.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index aefcad8..4fe1e7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,10 +58,10 @@ CLEANFILES += py/*.pyc py/mock/*.pyc py/mock/plugins/*.pyc
dist: ChangeLog AUTHORS
ChangeLog:
- (GIT_DIR=.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ (GIT_DIR=.git git log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
AUTHORS:
- (GIT_DIR=.git git-log | grep ^Author | sort |uniq > .authors.tmp && mv .authors.tmp AUTHORS; rm -f .authors.tmp) || (touch AUTHORS; echo 'git directory not found: installing possibly empty AUTHORS.' >&2)
+ (GIT_DIR=.git git log | grep ^Author | sort |uniq > .authors.tmp && mv .authors.tmp AUTHORS; rm -f .authors.tmp) || (touch AUTHORS; echo 'git directory not found: installing possibly empty AUTHORS.' >&2)
REPLACE_VARS_ON_INSTALL=$(sbindir)/mock.py
install-exec-hook: