summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael E Brown <mebrown@michaels-house.net>2007-12-01 03:24:38 -0600
committerMichael E Brown <mebrown@michaels-house.net>2007-12-01 03:24:38 -0600
commit6532fd66f7e9d82229a729dbe54305388402fcf5 (patch)
tree6ca101475738ac966910dbe3b231ba46abf2236b /Makefile.am
parent9b003eb043da10c98953c813ed01b0005ce6b075 (diff)
downloadmock-6532fd66f7e9d82229a729dbe54305388402fcf5.tar.gz
mock-6532fd66f7e9d82229a729dbe54305388402fcf5.tar.xz
mock-6532fd66f7e9d82229a729dbe54305388402fcf5.zip
move build of daemontest into makefile.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9c683fa..98a531a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,8 @@ DISTCLEANFILES=*~
EXTRA_DIST =
bin_PROGRAMS=
-EXTRA_PROGRAMS=
+check_PROGRAMS= src/daemontest
+#TESTS = docs/make_check.sh
CLEANFILES += $(EXTRA_PROGRAMS)
@@ -70,6 +71,7 @@ install-exec-hook:
perl -p -i -e 's|^PKGDATADIR=.*|PKGDATADIR="$(pkgdatadir)"|' $$file ;\
done
+.PHONY: rpm srpm
rpm: dist
BLD_DIR=$$(mktemp -d /tmp/rpmbuild-$$$$-XXXXXX); \
mkdir -p $$BLD_DIR/SOURCES $$BLD_DIR/BUILD $$BLD_DIR/RPMS $$BLD_DIR/RPMS/i386 $$BLD_DIR/RPMS/noarch $$BLD_DIR/SRPMS $$BLD_DIR/SPECS ;\