summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorClark Williams <williams@redhat.com>2009-11-16 16:16:51 -0600
committerClark Williams <williams@redhat.com>2009-11-16 16:16:51 -0600
commit18aeb5b777522236302916abefe22b89431383d5 (patch)
treeffa186f1cc089e5b6c2fbb7c103c3961dd14b698 /Makefile.am
parent725e8dd67a14cdec821dbd74df4467d9a76558c7 (diff)
downloadmock-18aeb5b777522236302916abefe22b89431383d5.tar.gz
mock-18aeb5b777522236302916abefe22b89431383d5.tar.xz
mock-18aeb5b777522236302916abefe22b89431383d5.zip
version bump to 0.9.20mock-0.9.20
Added autoconf/automake mojo to choose rpmbuild-md5 if available Signed-off-by: Clark Williams <williams@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4fe1e7d..41ea8a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,15 +90,21 @@ RPM_DEFINES = --define "_topdir $(TOPDIR)" \
--define "_specdir $(SPECDIR)" \
--define "_srcrpmdir $(SRCRPMDIR)"
+if USE_MD5
+RPMBUILD := rpmbuild-md5
+else
+RPMBUILD := rpmbuild
+endif
+
.PHONY: rpm srpm help
rpm: dist
mkdir -p $(BUILDDIR)
- rpmbuild $(RPM_DEFINES) -ba --nodeps $(PACKAGE_NAME).spec
+ $(RPMBUILD) $(RPM_DEFINES) -ba --nodeps $(PACKAGE_NAME).spec
rm -rf $(BUILDDIR)
srpm: dist
mkdir -p $(BUILDDIR)
- rpmbuild $(RPM_DEFINES) -bs --nodeps $(PACKAGE_NAME).spec
+ $(RPMBUILD) $(RPM_DEFINES) -bs --nodeps $(PACKAGE_NAME).spec
rm -rf $(BUILDDIR)