summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2009-07-20 10:11:03 -1000
committerDavid Cantrell <dcantrell@redhat.com>2009-07-22 15:17:40 -1000
commit73c5610adfb315d49f52a01a0a5808d4a198388b (patch)
tree49b9f7e51afb36fc0803d2e99eed206f57994762 /scripts/Makefile.am
parenta62ef457380ec9cfd589994e82752d74820038aa (diff)
downloadanaconda-73c5610adfb315d49f52a01a0a5808d4a198388b.tar.gz
anaconda-73c5610adfb315d49f52a01a0a5808d4a198388b.tar.xz
anaconda-73c5610adfb315d49f52a01a0a5808d4a198388b.zip
Add scripts/makeupdates to generate updates.img files.
Move the contents of the 'make updates' target to scripts/makeupdates. Make the recompilation of the _isys module be conditional (if you want to do that, either run 'make updates' as you have been or pass -c to scripts/makeupdates). Running makeupdates without -c will generate an updates.img with just the changed Python files.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 1f2352abe..1c5933877 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -22,6 +22,7 @@ dist_scripts_SCRIPTS = upd-instroot mk-images buildinstall \
buildinstall.functions scrubtree getkeymaps \
makestamp.py maketreeinfo.py upd-updates
dist_scripts_DATA = mk-images.* pyrc.py
-dist_noinst_SCRIPTS = getlangnames.py upd-bootimage upd-initrd upd-kernel
+dist_noinst_SCRIPTS = getlangnames.py upd-bootimage upd-initrd upd-kernel \
+ makeupdates
MAINTAINERCLEANFILES = Makefile.in