summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid King <amigadave@amigadave.com>2015-05-07 10:49:50 +0700
committerDavid King <amigadave@amigadave.com>2015-05-07 10:54:50 +0700
commit01c9d0edc407187b1bc6fb94b94d06d6054be7ba (patch)
tree18cbee39a55ad78dc6abaebb1967a035b417c39f /configure.ac
parentb0d895dafa2e56765a5ea01d17eda773d3e0142c (diff)
downloadc-gnome-app-01c9d0edc407187b1bc6fb94b94d06d6054be7ba.tar.gz
c-gnome-app-01c9d0edc407187b1bc6fb94b94d06d6054be7ba.tar.xz
c-gnome-app-01c9d0edc407187b1bc6fb94b94d06d6054be7ba.zip
Add skeleton build system
Run "autoreconf --force --install" to create the build system, then run "./configure" to check for necessary dependencies, such as make. Finally, run "make install" to install (into the default prefix). Examine the output from "./configure --help" to learn how to change the prefix and other installation settings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..1d1ade1
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,15 @@
+AC_INIT([C GNOME App],
+ [0.1],
+ [amigadave@amigadave.com],
+ [c-gnome-app],
+ [http://fedorapeople.org/cgit/amigadave/public_git/python-gnome-app.git/])
+
+AM_INIT_AUTOMAKE([1.11 foreign])
+
+PKG_CHECK_MODULES([APP], [gtk+-3.0 >= 3.12])
+
+AC_PROG_CC
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT