summaryrefslogtreecommitdiffstats
path: root/xbmc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'xbmc.spec')
-rw-r--r--xbmc.spec32
1 files changed, 5 insertions, 27 deletions
diff --git a/xbmc.spec b/xbmc.spec
index 1531500..6b366ed 100644
--- a/xbmc.spec
+++ b/xbmc.spec
@@ -5,7 +5,7 @@
Name: xbmc
Version: 12.2
-Release: 1%{?dist}
+Release: 1.1%{?dist}
URL: http://www.xbmc.org/
Source0: %{name}-%{DIRVERSION}-patched.tar.xz
@@ -33,14 +33,9 @@ Patch1: xbmc-12.0-pvraddons-with-dependencies.patch
# http://trac.xbmc.org/ticket/9658
Patch2: xbmc-12.2-dvdread.patch
-# need to file trac ticket, this patch just forces external hdhomerun
-# functionality, needs to be able fallback internal version
-Patch3: xbmc-12.2-hdhomerun.patch
-
# Optional deps (not in EPEL)
# (libbluray in EPEL 6 is too old.)
-%{?fedora:%global _with_hdhomerun 1}
%ifarch x86_64 i686
%{?fedora:%global _with_crystalhd 1}
%endif
@@ -121,9 +116,6 @@ BuildRequires: faad2-devel
BuildRequires: pulseaudio-libs-devel
BuildRequires: libdca-devel
BuildRequires: libass-devel >= 0.9.7
-%if 0%{?_with_hdhomerun}
-BuildRequires: hdhomerun-devel
-%endif
%if 0%{?_with_crystalhd}
BuildRequires: libcrystalhd-devel
%endif
@@ -171,9 +163,6 @@ BuildRequires: libva-devel
# as they are dynamically loaded via XBMC's arcane
# pseudo-DLL loading scheme (sigh)
Requires: librtmp
-%if 0%{?_with_hdhomerun}
-BuildRequires: hdhomerun
-%endif
%if 0%{?_with_crystalhd}
Requires: libcrystalhd
%endif
@@ -221,20 +210,6 @@ forecast functions, together third-party plugins.
%patch1 -p1
%patch2 -p1
-%patch3 -p1
-
-%if 0%{?_with_hdhomerun}
-%else
- # Remove hdhomerun from the build.
- pushd xbmc/filesystem/
- rm HDHomeRunFile.cpp HDHomeRunFile.h
- rm HDHomeRunDirectory.cpp HDHomeRunDirectory.h
- sed -i Makefile.in -e '/HDHomeRunFile\.cpp/d'
- sed -i Makefile.in -e '/HDHomeRunDirectory\.cpp/d'
- sed -i DirectoryFactory.cpp -e '/HomeRun/d'
- sed -i FileFactory.cpp -e '/HomeRun/d'
- popd
-%endif
%build
@@ -260,7 +235,7 @@ CPPFLAGS="-I/usr/include/ffmpeg" \
CFLAGS="$RPM_OPT_FLAGS -fPIC -I/usr/include/afpfs-ng/ -I/usr/include/ffmpeg -I/usr/include/samba-4.0/ -D__STDC_CONSTANT_MACROS" \
CXXFLAGS="$RPM_OPT_FLAGS -fPIC -I/usr/include/afpfs-ng/ -I/usr/include/ffmpeg -I/usr/include/samba-4.0/ -D__STDC_CONSTANT_MACROS" \
LDFLAGS="-fPIC" \
-LIBS="-L%{_libdir}/mysql %{?_with_hdhomerun:-lhdhomerun} $LIBS" \
+LIBS="-L%{_libdir}/mysql $LIBS" \
ASFLAGS=-fPIC
make %{?_smp_mflags} VERBOSE=1
@@ -327,6 +302,9 @@ fi
#%%{_includedir}/xbmc/xbmcclient.h
%changelog
+* Fri May 17 2013 Ken Dreyer <ktdreyer@ktdreyer.com> - 12.2-1.1
+- Revert to building with internal hdhomerun fork
+
* Mon May 06 2013 Ken Dreyer <ktdreyer@ktdreyer.com> - 12.2-1
- Update to Frodo 12.2
- Rebase hdhomerun and dvdread patches onto 12.2