summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..076fb33
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+from distribute_setup import use_setuptools
+use_setuptools()
+
+from setuptools import setup, find_packages
+
+setup(
+ name="KittyStore",
+ version="0.1",
+ description="A storage engine for GNU Mailman v3 archives",
+ long_description=open('README.rst').read(),
+ url="https://fedorahosted.org/hyperkitty/",
+ packages=find_packages(exclude=["*.test", "test", "*.test.*"]),
+ include_package_data=True,
+ install_requires=[
+ 'mailman',
+ 'zope.interface',
+ 'SQLAlchemy==0.7.8',
+ 'python-dateutil < 2.0' # 2.0+ is for Python 3
+ ],
+ )