summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py19
1 files changed, 16 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index bc16eae..eaf105b 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,8 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-import ez_setup
-ez_setup.use_setuptools()
+from distribute_setup import use_setuptools
+use_setuptools()
from setuptools import setup, find_packages
@@ -11,8 +11,21 @@ setup(
version="0.1",
description="A web interface to access GNU Mailman v3 archives",
long_description=open('README.rst').read(),
+ author='HyperKitty Developers',
+ author_email='hyperkitty-devel@lists.fedorahosted.org',
url="https://fedorahosted.org/hyperkitty/",
- packages=find_packages(exclude=["*.test", "test", "*.test.*"]),
+ license="GPLv3",
+ classifiers=[
+ "Framework :: Django",
+ "Development Status :: 3 - Alpha",
+ "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+ "Topic :: Communications :: Email :: Mailing List Servers",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: JavaScript",
+ ],
+ keywords='email',
+ #packages=find_packages(exclude=["*.test", "test", "*.test.*"]),
+ packages=find_packages(),
include_package_data=True,
install_requires=open('requirements.txt').read(),
)