summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Alves <simpledark+manasource@gmail.com>2010-07-22 22:06:03 +0200
committerBernd Wachter <bwachter-mana@lart.info>2010-07-23 12:22:19 +0300
commit4cf651528127aeac71b8df45b9ffcc0fd2cf64ad (patch)
treecbd66af2265f57412d39f42c218e0fe80fd3bd35 /src/CMakeLists.txt
parent89d1862497222ea48fb38995492df7947b00c4d7 (diff)
downloadmanaserv-4cf651528127aeac71b8df45b9ffcc0fd2cf64ad.tar.gz
manaserv-4cf651528127aeac71b8df45b9ffcc0fd2cf64ad.tar.xz
manaserv-4cf651528127aeac71b8df45b9ffcc0fd2cf64ad.zip
Fixing compatibility with cmake 2.6.0
The syntax IF ((condition) OR (condition)) is not accepted by cmake prior to 2.6.4. The patch should address this without affecting newer versions.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 69393de..b7c0641 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -67,8 +67,8 @@ ENDIF()
IF (CMAKE_BUILD_TYPE)
STRING(TOLOWER ${CMAKE_BUILD_TYPE} CMAKE_BUILD_TYPE_TOLOWER)
- IF((CMAKE_BUILD_TYPE_TOLOWER MATCHES debug) OR
- (CMAKE_BUILD_TYPE_TOLOWER MATCHES relwithdebinfo))
+ IF(CMAKE_BUILD_TYPE_TOLOWER MATCHES debug OR
+ CMAKE_BUILD_TYPE_TOLOWER MATCHES relwithdebinfo)
SET(FLAGS "${FLAGS} -DDEBUG")
ENDIF()
ENDIF()