summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Marks <nymacro@gmail.com>2005-11-14 08:50:25 +0000
committerAaron Marks <nymacro@gmail.com>2005-11-14 08:50:25 +0000
commit9c4f838ef2e9b801a08c3550647aff4efcbb1ebd (patch)
treeb8bc83cc47357173ef439f263b81b5c3775f3350 /configure.ac
parentf14d517cd6bb949e935f5c5401dfdf81bbf7ab4f (diff)
downloadmanaserv-9c4f838ef2e9b801a08c3550647aff4efcbb1ebd.tar.gz
manaserv-9c4f838ef2e9b801a08c3550647aff4efcbb1ebd.tar.xz
manaserv-9c4f838ef2e9b801a08c3550647aff4efcbb1ebd.zip
Added intial SWIG bindings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0a03bbf..758e76c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,7 +119,18 @@ AC_ARG_WITH(
)
if test "$with_scripting_engine" = "ruby"; then
- AC_MSG_ERROR([sorry, $with_scripting_engine is not supported yet])
+ # AC_MSG_ERROR([sorry, $with_scripting_engine is not supported yet])
+ AC_CHECK_LIB([ruby], [ruby_init])
+ AC_PATH_PROG(swig_path, swig, no)
+ if test "$swig_path" = "no"; then
+ AC_MSG_ERROR(Could not find swig in PATH)
+ fi
+ SWIG="$swig_path"
+ SWIGFLAGS="-c++ -ruby -minherit"
+ AC_SUBST(SWIG)
+ AC_SUBST(SWIGFLAGS)
+ CXXFLAGS="$CXXFLAGS -DSCRIPT_SUPPORT -DRUBY_SUPPORT -I/usr/lib/ruby/1.8/linux/"
+ LIBS="$LIBS -lruby"
elif test "$with_scripting_engine" = "squirrel"; then
AC_CHECK_LIB([squirrel], [sq_open])