summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2008-11-16 19:15:42 +0100
committerBjørn Lindeijer <bjorn@lindeijer.nl>2008-11-16 19:15:42 +0100
commit72c81f37b06d9cbd8edfa2b90929a793936a15fb (patch)
tree26cd8d4250b0aff44075e44f6f536bd7175a2e66 /configure.ac
parent614242263887cd0df5524191c0b02c912ed1bf7e (diff)
downloadmanaserv-72c81f37b06d9cbd8edfa2b90929a793936a15fb.tar.gz
manaserv-72c81f37b06d9cbd8edfa2b90929a793936a15fb.tar.xz
manaserv-72c81f37b06d9cbd8edfa2b90929a793936a15fb.zip
Added a raw check for liblua 5.1 to configure
For when pkg-config files aren't available. They most often are not when Lua was installed manually, not sure if they come with the Lua distribution at all.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d8ef919..6602a7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,8 +97,10 @@ AC_ARG_ENABLE(
)
if test "$enable_lua_engine" = "yes"; then
- PKG_CHECK_MODULES(LUA, [lua >= 5.1], ,
- [PKG_CHECK_MODULES(LUA, [lua5.1 >= 5.1])])
+ PKG_CHECK_MODULES(LUA, [lua >= 5.2], ,
+ [PKG_CHECK_MODULES(LUA, [lua5.1 >= 5.2], ,
+ [AC_CHECK_LIB([lua5.1], [lua_newstate], ,
+ AC_MSG_ERROR([ *** Unable to find liblua 5.1]))])])
CXXFLAGS="$CXXFLAGS $LUA_CFLAGS"
LIBS="$LIBS $LUA_LIBS"
fi