summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMateusz Kaduk <mateusz.kaduk@gmail.com>2005-06-19 15:19:50 +0000
committerMateusz Kaduk <mateusz.kaduk@gmail.com>2005-06-19 15:19:50 +0000
commit502fe0a533a1bfb967e12c61fc897b853cf3dd10 (patch)
treefcb20084b2599c0c69774ebed682d32485cceea4 /configure.ac
parent46ccf57109ea187d83017218d4ac8ff36628b8b9 (diff)
downloadmanaserv-502fe0a533a1bfb967e12c61fc897b853cf3dd10.tar.gz
manaserv-502fe0a533a1bfb967e12c61fc897b853cf3dd10.tar.xz
manaserv-502fe0a533a1bfb967e12c61fc897b853cf3dd10.zip
Fixed AMDEP configure problem. Basing on http://lists.gnu.org/archive/html/automake/2005-01/msg00034.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index a60a209..78acd96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,17 @@ AC_INIT([TMW Server], [0.0.1], [b_lindeijer@users.sourceforge.net])
AC_CONFIG_HEADERS([config.h:config.h.in])
AM_INIT_AUTOMAKE
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+
+# Checks for library functions.
+AC_CHECK_FUNCS([atexit])
+
# Check if with sqlite
AC_ARG_WITH(sqlite,[ --with-sqlite support SQLite ] )
if test "x$with_sqlite" == "xyes"; then
@@ -93,16 +104,6 @@ else
with_scripting=no
fi
-# Checks for header files.
-AC_HEADER_STDC
-AC_CHECK_HEADERS([string.h])
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_STDBOOL
-AC_C_CONST
-
-# Checks for library functions.
-AC_CHECK_FUNCS([atexit])
AC_CONFIG_FILES([Makefile
src/Makefile])