summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2005-05-21 11:09:16 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2005-05-21 11:09:16 +0000
commit4c76ce2603ef8882941d6cdea6abb7d53b240ebc (patch)
tree92a9a16aa848ccb95b50ef1aff228df7b5a1999e /configure.ac
parentfff37ac56a093ca1659d03d7fca339d96f6a931f (diff)
downloadmanaserv-4c76ce2603ef8882941d6cdea6abb7d53b240ebc.tar.gz
manaserv-4c76ce2603ef8882941d6cdea6abb7d53b240ebc.tar.xz
manaserv-4c76ce2603ef8882941d6cdea6abb7d53b240ebc.zip
Print error when trying to build with scripting but without Squirrel installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a3b7e67..29a898b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,10 +8,10 @@ PKG_CHECK_MODULES(SQLITE, [sqlite3 >= 3.0.6],
[],
[AC_MSG_ERROR([Cannot find SQLite 3])]
)
-
+
AC_SUBST(SQLITE_CFLAGS)
AC_SUBST(SQLITE_LIBS)
-
+
# Checks for programs.
AC_PROG_CXX
AC_PROG_CC
@@ -23,7 +23,8 @@ AC_CHECK_LIB([SDL_net], [SDLNet_Init])
AC_ARG_WITH(scripting,[ --with-scripting Build with scripting])
if test "x$with_scripting" == "xyes"; then
- AC_CHECK_LIB([squirrel], [sq_open])
+ AC_CHECK_LIB([squirrel], [sq_open], ,
+ AC_MSG_ERROR([Cannot find Squirrel library (squirrel.sf.net)]))
with_scripting=yes
SCRIPT_CFLAGS=' -DSCRIPT_SUPPORT'