summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2009-05-24 17:24:51 +0200
committerBjørn Lindeijer <bjorn@lindeijer.nl>2009-05-24 17:27:00 +0200
commit454c2e4345c74afa8ee80dc95228d9563cbe5314 (patch)
tree75af19fb7bec07bf2f5536dc6e7c67b74bd9375e /configure.ac
parent346a56602177251827e8e10419a2d6ef63a0679b (diff)
downloadmanaserv-454c2e4345c74afa8ee80dc95228d9563cbe5314.tar.gz
manaserv-454c2e4345c74afa8ee80dc95228d9563cbe5314.tar.xz
manaserv-454c2e4345c74afa8ee80dc95228d9563cbe5314.zip
Fixed the Lua check to also accept plain liblua.a
By default the Lua library is simply called liblua.a, while on Debian it is renamed due to incompatibilities among Lua versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 518937b..842e4b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,7 +98,8 @@ if test "$enable_lua_engine" = "yes"; then
PKG_CHECK_MODULES(LUA, [lua >= 5.1], ,
[PKG_CHECK_MODULES(LUA, [lua5.1 >= 5.1], ,
[AC_CHECK_LIB([lua-5.1], [lua_newstate], ,
- AC_MSG_ERROR([ *** Unable to find liblua 5.1]))])])
+ [AC_CHECK_LIB([lua], [lua_newstate], ,
+ AC_MSG_ERROR([ *** Unable to find liblua 5.1]))])])])
CXXFLAGS="$CXXFLAGS $LUA_CFLAGS"
LIBS="$LIBS $LUA_LIBS"
fi