summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-01-02 13:26:47 +0000
committerGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-01-02 13:26:47 +0000
commit0a47b2fb30c83f8b021c2015891fe8c936ca6bf0 (patch)
tree21525442898ca4e41eb8ab51a16cf5384ffef40c /configure.ac
parent5999cff421b0e0b5cd7a0da4d4b0a492f8cc303b (diff)
downloadmanaserv-0a47b2fb30c83f8b021c2015891fe8c936ca6bf0.tar.gz
manaserv-0a47b2fb30c83f8b021c2015891fe8c936ca6bf0.tar.xz
manaserv-0a47b2fb30c83f8b021c2015891fe8c936ca6bf0.zip
Removed obsolete files. Added a generic trigger system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 1 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 5dc70cf..9a88565 100644
--- a/configure.ac
+++ b/configure.ac
@@ -139,23 +139,6 @@ elif test "$with_scripting_engine" != "no"; then
fi
-# Checks for the unit tests.
-AC_ARG_ENABLE(
- [unit-tests],
- AS_HELP_STRING([--enable-unit-tests], [compile the unit tests]),
- [if test "$enableval" = "yes"; then
- enable_unit_tests="$enableval"
-
- # use cppunit-config to check the libcppunit.
- # CPPUNIT_CFLAGS and CPPUNIT_LIBS are set by AC_CHECK_LIB_TMW.
- AC_CHECK_LIB_TMW([cppunit], [1.10.2])
- else
- enable_unit_tests="no"
- fi],
- [enable_unit_tests="no"]
-)
-
-
AM_CONDITIONAL(BUILD_MYSQL, test "$with_storage_backend" = "mysql")
AM_CONDITIONAL(BUILD_POSTGRESQL, test "$with_storage_backend" = "postgresql")
AM_CONDITIONAL(BUILD_SQLITE, test "$with_storage_backend" = "sqlite")
@@ -163,12 +146,7 @@ AM_CONDITIONAL(BUILD_SQLITE, test "$with_storage_backend" = "sqlite")
AM_CONDITIONAL(BUILD_RUBY, test "$with_scripting_engine" = "ruby")
AM_CONDITIONAL(BUILD_SQUIRREL, test "$with_scripting_engine" = "squirrel")
-AM_CONDITIONAL(UNIT_TESTS_YES, test "$enable_unit_tests" = "yes")
-
-
-AC_CONFIG_FILES([Makefile
- src/Makefile
- src/tests/Makefile])
+AC_CONFIG_FILES([Makefile src/Makefile])
AC_OUTPUT