summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlexander Bokovoy <abokovoy@redhat.com>2014-07-29 12:04:34 +0300
committerAlexander Bokovoy <abokovoy@redhat.com>2014-10-10 11:58:23 +0300
commit08b596b5040af4df34bc2d8dfab8283d5938c448 (patch)
treefaf058de7d0ecf13841a9587dc917651db94d6b5 /src/Makefile.am
parent7e319653c352da1e8c6354bc8f95a2306d70c54b (diff)
downloadslapi-nis-08b596b5040af4df34bc2d8dfab8283d5938c448.tar.gz
slapi-nis-08b596b5040af4df34bc2d8dfab8283d5938c448.tar.xz
slapi-nis-08b596b5040af4df34bc2d8dfab8283d5938c448.zip
Add support for FreeIPA ID views
FreeIPA ID views allow to override POSIX attributes for certain users and groups. A support is added to allow using specific ID view when serving compatibility tree. Each user or group entry which has an override in the view is amended with the overridden values from the view before served out to the LDAP client. A view to use is specified as a part of base DN: cn=<view>,cn=views,cn=compat,$SUFFIX where cn=compat,$SUFFIX is the original compatibility tree base DN. Each entry, when served through the view, gets new DN rewritten to specify the view. Additionally, if override in the view changes uid (for users) or cn (for groups) attribute, the entry's RDN is changed accordingly. For groups memberUid attribute is modified as well in case there is an override in the view that changes uid value of that member. FreeIPA ID views support overrides for users of trusted Active Directory domains. In case of a trusted AD domain's user or group is returned via compatibility tree, view overrides are applied in two stages: 1. SSSD applies default view for AD users 2. slapi-nis applies explicitly specified (host-specific) view on top of the entry returned by SSSD Thus, slapi-nis does not need to apply default view for AD users and if there are no host-specific views in use, there is no need to specify a view in the base DN, making overhead of a default view for AD users lower.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e4fe1a9..6f4926e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -78,6 +78,10 @@ schemacompat_plugin_la_SOURCES += back-sch-pam.c
schemacompat_plugin_la_LIBADD += $(PAM_LIBS)
endif
+if USE_IPA_IDVIEWS
+schemacompat_plugin_la_SOURCES += back-sch-idview.c
+endif
+
noinst_LTLIBRARIES = dummy-nis-plugin.la
dummy_nis_plugin_la_SOURCES = \
disp-nis.c \