summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-06-10 16:12:14 -0400
committerNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-06-10 16:12:14 -0400
commitfe4981c670912bbe0eababbf23e1fba9471fde86 (patch)
tree76b74a37746347d1e1298243759010876f948dce /configure.ac
parent84f52c6115c570ca2299f358d9d5dd9be2b24266 (diff)
downloadslapi-nis-fe4981c670912bbe0eababbf23e1fba9471fde86.tar.gz
slapi-nis-fe4981c670912bbe0eababbf23e1fba9471fde86.tar.xz
slapi-nis-fe4981c670912bbe0eababbf23e1fba9471fde86.zip
- settle on more unique attribute names for configuration options
- note that it works now - include example configuration
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 11 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 65ae15d..aea1c18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,37 +116,37 @@ AC_DEFINE(DEFAULT_TARGET_REPLY_SIZE,(4 * 1024),[Define to the default target siz
baseattr=base
AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_BASE_ATTR,"$baseattr",
[Define to name of the attribute which lists the containers for entries for a given map.])
-filterattr=filter
+filterattr=nis-filter
AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_FILTER_ATTR,"$filterattr",
[Define to name of the attribute which holds the filter for selecting entries for a given map.])
-keyformatattr=keyFormat
+keyformatattr=nis-key-format
AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_KEY_ATTR,"$keyformatattr",
[Define to name of the map configuration attribute which holds the format specifier for the key for a map entry.])
-valueformatattr=valueFormat
+valueformatattr=nis-value-format
AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_VALUE_ATTR,"$valueformatattr",
[Define to name of the map configuration attribute which holds the format specifier for the value for a map entry.])
-domainattr=domain
+domainattr=nis-domain
AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_DOMAIN_ATTR,"$domainattr",
[Define to name of the map configuration attribute which holds the name of the domain of the map.])
-mapattr=map
+mapattr=nis-map
AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_MAP_ATTR,"$mapattr",
[Define to name of the map configuration attribute which holds the name of the map.])
-secureattr=secure
+secureattr=nis-secure
AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_SECURE_ATTR,"$secureattr",
[Define to name of the map configuration attribute which determines whether or not the map is treated a 'secure' map.])
-maxvalue_attr=nis-plugin-max-value-size
+maxvalue_attr=nis-max-value-size
AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_MAXVALUE_ATTR,"$maxvalue_attr",
[Define to the name of the plugin configuration attribute which holds the maximum size for a NIS entry value.])
-maxdgram_attr=nis-plugin-max-dgram-size
+maxdgram_attr=nis-max-dgram-size
AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_MAXDGRAM_ATTR,"$maxdgram_attr",
[Define to the name of the plugin configuration attribute which holds the maximum size for a NIS datagram response.])
-securenet_attr=nis-plugin-securenet
+securenet_attr=nis-securenet
AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_SECURENET_ATTR,"$securenet_attr",
[Define to the name of the plugin configuration attribute which holds a securenets entry.])
-tcpwrapname_attr=nis-plugin-tcp-wrappers-name
+tcpwrapname_attr=nis-tcp-wrappers-name
AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_TCPWRAPNAME_ATTR,"$tcpwrapname_attr",
[Define to the name of the plugin configuration attribute which holds service name that will be used when evaluating hosts.allow and hosts.deny.])
-port_attr=nis-plugin-port
+port_attr=nsslapd-pluginarg0
AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_PORT_ATTR,"$port_attr",
[Define to the name of the plugin configuration attribute which holds the port which the server should use by default. If none is specified, the server will attempt to use any available port.])
AC_SUBST(domainattr)