summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-07-08 14:32:34 -0400
committerNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-07-08 14:32:34 -0400
commit9fe18a0d9f5ed00295b5601b22bf2143b8012f5b (patch)
tree9c9acab10a319aa70a82f87ecae5c5833dbe3950 /configure.ac
parent899ab1307290b15a33a1ad8d1513fe395c1f617c (diff)
downloadslapi-nis-9fe18a0d9f5ed00295b5601b22bf2143b8012f5b.tar.gz
slapi-nis-9fe18a0d9f5ed00295b5601b22bf2143b8012f5b.tar.xz
slapi-nis-9fe18a0d9f5ed00295b5601b22bf2143b8012f5b.zip
- add framework for adding a test suite
- provide a way to get the nis plugin to run more or less unprivileged
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 29 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 541b5e2..f864337 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,5 +197,33 @@ AC_SUBST(schentryformatattr)
AC_SUBST(groupattr)
AC_SUBST(containerattr)
+AC_PATH_PROG(SLAPD,[ns-slapd],no-slapd,[$PATH$PATH_SEPARATOR/usr/sbin$PATH_SEPARATOR/usr/libexec])
+AC_PATH_PROG(RPCGEN,[rpcgen],no-rpcgen,[$PATH$PATH_SEPARATOR/usr/sbin$PATH_SEPARATOR/usr/libexec])
+AM_CONDITIONAL(CAN_TEST,[test "$server" = dirsrv && test "$SLAPD" != no-slapd && test "$RPCGEN" != no-rpcgen])
+AC_SUBST(CAN_TEST)
+test_user=`id -un`
+AC_SUBST(test_user)
+test_basedn=dc=example,dc=com
+AC_SUBST(test_basedn)
+while true ; do
+ test_ldapport=$RANDOM
+ if test $test_ldapport -ge 1024 ; then
+ break
+ fi
+done
+AC_SUBST(test_ldapport)
+while true ; do
+ test_nisport=$RANDOM
+ if test $test_nisport -ge 1024 ; then
+ break
+ fi
+done
+AC_SUBST(test_nisport)
+NIS_PLUGIN_CONTINUE_WITHOUT_PORTMAP_ENV="nis_plugin_continue_without_portmap_for_testing_only_no_i_really_mean_that"
+AC_DEFINE_UNQUOTED(NIS_PLUGIN_CONTINUE_WITHOUT_PORTMAP_ENV,"$NIS_PLUGIN_CONTINUE_WITHOUT_PORTMAP_ENV",[Define to the environment variable which will override the fail-if-unable-to-use-the-portmapper logic.])
+AC_SUBST(NIS_PLUGIN_CONTINUE_WITHOUT_PORTMAP_ENV)
+
AC_CONFIG_HEADER(config.h)
-AC_OUTPUT(Makefile src/Makefile doc/nis-plugin.ldif doc/sch-plugin.ldif)
+AC_OUTPUT(Makefile src/Makefile doc/nis-plugin.ldif doc/sch-plugin.ldif
+ tests/Makefile tests/clients/Makefile
+ tests/slapd.sh tests/config/dse.ldif.initial)