summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-06-30 13:53:50 -0400
committerNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-06-30 13:53:50 -0400
commit72952b388c123d655a662891646816dad761366b (patch)
tree50ac1c5f8a109e2e3d3747526c6432b2ace120ee /configure.ac
parent3c05a9b02284049f7f38b868a8dc9a5c97b266a0 (diff)
downloadslapi-nis-72952b388c123d655a662891646816dad761366b.tar.gz
slapi-nis-72952b388c123d655a662891646816dad761366b.tar.xz
slapi-nis-72952b388c123d655a662891646816dad761366b.zip
- namespace nis-specific configuration
- format doesn't care about the secure flag, so don't bother returning its value
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 24 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index c235b2b..5f764a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,54 +113,55 @@ AC_DEFINE(DEFAULT_MAX_DGRAM_SIZE,YPMAXRECORD,[Define to the default maximum data
AC_DEFINE(DEFAULT_MAX_VALUE_SIZE,(256 * 1024),[Define to the default maximum map entry key and value size.])
AC_DEFINE(DEFAULT_TARGET_REPLY_SIZE,(4 * 1024),[Define to the default target size for a connected reply fragment.])
-baseattr=nis-base
-AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_BASE_ATTR,"$baseattr",
+nisbaseattr=nis-base
+AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_BASE_ATTR,"$nisbaseattr",
[Define to name of the attribute which lists the containers for entries for a given map.])
-filterattr=nis-filter
-AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_FILTER_ATTR,"$filterattr",
+nisfilterattr=nis-filter
+AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_FILTER_ATTR,"$nisfilterattr",
[Define to name of the attribute which holds the filter for selecting entries for a given map.])
-keyformatattr=nis-key-format
-AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_KEY_ATTR,"$keyformatattr",
+niskeyformatattr=nis-key-format
+AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_KEY_ATTR,"$niskeyformatattr",
[Define to name of the map configuration attribute which holds the format specifier for single keys for a map entry.])
-keysformatattr=nis-keys-format
-AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_KEYS_ATTR,"$keysformatattr",
+niskeysformatattr=nis-keys-format
+AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_KEYS_ATTR,"$niskeysformatattr",
[Define to name of the map configuration attribute which holds the format specifier for possibly-multiple keys for a map entry.])
-valueformatattr=nis-value-format
-AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_VALUE_ATTR,"$valueformatattr",
+nisvalueformatattr=nis-value-format
+AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_VALUE_ATTR,"$nisvalueformatattr",
[Define to name of the map configuration attribute which holds the format specifier for the value for a map entry.])
domainattr=nis-domain
-AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_DOMAIN_ATTR,"$domainattr",
+AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_DOMAIN_ATTR,"$domainattr",
[Define to name of the map configuration attribute which holds the name of the domain of the map.])
mapattr=nis-map
-AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_MAP_ATTR,"$mapattr",
+AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_MAP_ATTR,"$mapattr",
[Define to name of the map configuration attribute which holds the name of the map.])
disallowedcharsattr=nis-disallowed-chars
-AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_DISALLOWED_CHARS_ATTR,"$disallowedcharsattr",
+AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_DISALLOWED_CHARS_ATTR,"$disallowedcharsattr",
[Define to the list of characters which should not be allowed in attribute values which are being considered.])
secureattr=nis-secure
-AC_DEFINE_UNQUOTED(MAP_CONFIGURATION_SECURE_ATTR,"$secureattr",
+AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_SECURE_ATTR,"$secureattr",
[Define to name of the map configuration attribute which determines whether or not the map is treated a 'secure' map.])
+
maxvalue_attr=nis-max-value-size
-AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_MAXVALUE_ATTR,"$maxvalue_attr",
+AC_DEFINE_UNQUOTED(NIS_PLUGIN_CONFIGURATION_MAXVALUE_ATTR,"$maxvalue_attr",
[Define to the name of the plugin configuration attribute which holds the maximum size for a NIS entry value.])
maxdgram_attr=nis-max-dgram-size
-AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_MAXDGRAM_ATTR,"$maxdgram_attr",
+AC_DEFINE_UNQUOTED(NIS_PLUGIN_CONFIGURATION_MAXDGRAM_ATTR,"$maxdgram_attr",
[Define to the name of the plugin configuration attribute which holds the maximum size for a NIS datagram response.])
securenet_attr=nis-securenet
-AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_SECURENET_ATTR,"$securenet_attr",
+AC_DEFINE_UNQUOTED(NIS_PLUGIN_CONFIGURATION_SECURENET_ATTR,"$securenet_attr",
[Define to the name of the plugin configuration attribute which holds a securenets entry.])
tcpwrapname_attr=nis-tcp-wrappers-name
-AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_TCPWRAPNAME_ATTR,"$tcpwrapname_attr",
+AC_DEFINE_UNQUOTED(NIS_PLUGIN_CONFIGURATION_TCPWRAPNAME_ATTR,"$tcpwrapname_attr",
[Define to the name of the plugin configuration attribute which holds service name that will be used when evaluating hosts.allow and hosts.deny.])
port_attr=nsslapd-pluginarg0
-AC_DEFINE_UNQUOTED(PLUGIN_CONFIGURATION_PORT_ATTR,"$port_attr",
+AC_DEFINE_UNQUOTED(NIS_PLUGIN_CONFIGURATION_PORT_ATTR,"$port_attr",
[Define to the name of the plugin configuration attribute which holds the port which the server should use by default. If none is specified, the server will attempt to use any available port.])
AC_SUBST(domainattr)
AC_SUBST(mapattr)
-AC_SUBST(baseattr)
-AC_SUBST(filterattr)
-AC_SUBST(keyformatattr)
-AC_SUBST(valueformatattr)
+AC_SUBST(nisbaseattr)
+AC_SUBST(nisfilterattr)
+AC_SUBST(niskeyformatattr)
+AC_SUBST(nisvalueformatattr)
AC_SUBST(maxvalue_attr)
AC_SUBST(maxdgram_attr)
AC_SUBST(securenet_attr)